How to modify the boot logo with JetPack_5.0.2_Linux_JETSON_XAVIER_NX_TARGETS

How to modify the boot logo with JetPack_5.0.2_Linux_JETSON_XAVIER_NX_TARGETS

Hello, this topic belongs here: Jetson & Embedded Systems - NVIDIA Developer Forums

I will move it over for you.

1 Like

Hi 2398492542,

Are you using the devkit or custom board for Xavier NX?

Please refer to the following instruction.
UEFI Adaptation — Jetson Linux
Developer Guide 34.1 documentation (

Hi,I want to remove uboot logo jetpack_5.1.1. HOW to deal with?

For Jetpack 5, we uses UEFI as bootloader instead of uboot.
You could also refer to the UEFI source to remove LogoDxe from config file.

I used the method you provided and got the following prompt in the terminal:
nvidia: building from workspace rooted at: /home/hz/nvidia-uefi
nvidia: found command: python3.
nvidia: found command: virtualenv.
nvidia: found command: mono.
nvidia: found command: aarch64-linux-gnu-gcc.
nvidia: found Python 3.9 or later.
nvidia: Activating Python virtual environment.
nvidia: Updating build environment (edk2-nvidia/Platform/NVIDIA/Jetson/
edk2-nvidia/Silicon/NVIDIA/scripts/ 行 41: stuart_update:command not found

This feels like the discovery and potential exploitation of the LogoFAIL vulnerability discovered by Binarly: Finding LogoFAIL: The Dangers of Image Parsing During System Boot | Binarly – AI -Powered Firmware Supply Chain Security Platform

Is NVIDIA looking to make the logo unmodifiable/protected in a security patch to the UEFI bootloader?

I have successfully applied the logo to the board, but the size of the logo is too small. Is there any way to change the size of the logo?

There should be 3 logo images with different resolution.
What do you mean about the “the size of the logo is too small”?
Which resolution is using currently?

1 Like

I’ve solved the problem, thank you very much. After restarting, it will display normally.
I manually modified the p3668.conf.common file. The modification content was to change
CMDLINE_ADD=“console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0”; to CMDLINE_ADD=“console=ttyTCU0,115200n8 fbcon =map:0 net.ifnames=0”;The purpose is to prevent kernel information from being printed when the system starts. How can I flash only the modified files into the system?

Since you are modifying the cmdline for kernel, you could also just modify it in /boot/extlinux/extlinux.conf from your board.

The contents of the /boot/extlinux/extlinux.conf file on the board are as follows:

DEFAULT primary

MENU TITLE L4T boot options

LABEL primary

  LINUX /boot/Image
  FDT /boot/dtb/kernel_tegra194-p3668-0001-p3509-0000.dtb
  INITRD /boot/initrd
  APPEND ${cbootargs} root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 nv-auto-config 

When testing a custom kernel, it is recommended that you create a backup of

the original kernel and add a new entry to this file so that the device can

fallback to the original kernel. To do this:

1, Make a backup of the original kernel

sudo cp /boot/Image /boot/Image.backup

2, Copy your custom kernel into /boot/Image

3, Uncomment below menu setting lines for the original kernel

4, Reboot

LABEL backup

MENU LABEL backup kernel

LINUX /boot/Image.backup

FDT /boot/dtb/kernel_tegra194-p3668-0001-p3509-0000.dtb

INITRD /boot/initrd

APPEND ${cbootargs}

How should I modify this file to ensure that the kernel log information will not be printed when the board starts up? What operations are required after the modification? I also want to ask what the role of TIMEOUT 30 in the first line of this file is. (643 Bytes)

Please just remove console=tty0 in above line.

I have tried this method. After deleting console=tty0, I tried restarting, but the kernel log information will still be printed.

I should do the same trick as you did before.

Which UART interface do you want to disable the debug message?
Have you also tried to remove console=ttyTCU0,115200n8?

Directly add the p3668.conf.common file in JetPack_5.0.2_Linux_JETSON_XAVIER_NX_TARGETS
CMDLINE_ADD=“console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0”; change it to CMDLINE_ADD=“console=ttyTCU0,115200n8 fbcon =map:0 net.ifnames=0”; and then refresh the system. I successfully set the kernel information not to be printed, but I tried modifying it directly in the extlinux.conf of the board several times without success.After trying to remove console=ttyTCU0, 115200n8 also failed to remove the kernel information printing.

Which UART interface do you see the logs output?

You could run cat /proc/cmdline to check if your modification take effects.

The output I get using cat /proc/cmdline is what the picture below shows:

From this picture, we can see that directly modifying extlinux.conf does not work. Are there any other modifications that need to be made? ?

It seems ttyTCU0 and tty0 still exist in kernel cmdline.
Please just modify it in board config and re-flash the board to apply the change.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.