How to modify the boot order on orin nx?

Dear nvdia team:
Now I have Orin NX module and our custom carrier board.I upgrade the firmware by the command below:
sudo ./tools/kernel_flash/ --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml” --showlogs --network usb0 p3509-a02+p3767-0000 internal
when it reboots, it shows the log below:

I burn the firmware to SSD defaultly,but it boots from the network.How to change the boot order ?

Hi fengzan.zhang,

Please refer to the following instruction to change boot order in UEFI.
Boot problem on live device - #8 by KevinFFF

You could remove network related boot options if you don’t use them.

“Step 1: Enter Boot Menu
When you see the NVIDIA logo at boot up, Press “ESC” to enter setup.”
I have tried it.But there is noting happen when I press ESC.I have inserted the keyboard to USB port and tried many times.What’s the reason?

Do you connect a monitor on your board for watching the UEFI menu?

There should be 5s delay as default in UEFI.
It should happen when you see the serial console log showed “** WARNING: Test Key is used”.

Yes, I have also tried the orin nx dekit and it can enter the UEFI when it boot by pressing ESC.But it’s strange not to work on our custom carrier board.

Is there any messages or log showed in serial console when you press ESC at that moment?

Are you sure the USB keyboard working with your custom board?

NO,nothing happen.I also suspect that USB does not work during startup. So I have tried to tap the keyboard when the system is started.It’s OK. Now we are checking this problem.How to make sure the USB working when startup?

Could you help to use debug UEFI to enable log for further check?

Does your custom carrier have the similar board design as p3509 (any related modification about USB)?
I noticed you are using p3509-a02+p3767-0000 as your board config.

How to enable UEFI log?
Yes, we use the p3509-a02+p3767-0000 board config
Related modification below:

Please refer to the following link for UEFI build and flash.
GitHub - NVIDIA/edk2-nvidia: NVIDIA EDK2 platform support

I had a try.But it always downloads failed below.What’s the reason?My network ping is OK.

When I use the build command,it shows the error below:

Could you help to run the edkrepo command without sudo?

I have tried so many times without sudo or with sudo,but it still can’t be downloaded.The download is extremely unstable and easy to disconnect.I don’t know why.Is there any other way to download?I used the second way by building without docker.

Hi fengzan.zhang
it is OK from my side, please check your network and try again.

Hello KevinFFF:
I have a problem. I tried to modify the system boot menu to move the USB disk boot to the top, but when the system started, it was still booted from SSD by default. I inserted both the flash drive and SSD which are the first and sixth items in the screenshot below.What is the reason for this?When I unplug the SSD, it starts normally from the U disk.

Do you “Save & Exit” after modifying the boot-order in UEFI menu?

and how do you verify which is the current boot device after you boot up?

of couse

When the system boots up.I can see by the df -h command below.

Could you select USB disk as boot device in UEFI directly when both USB disk and NVMe are connected?

I have already select USB disk to the first in UEFI.I have attached the screenshot below.It still boots from SSD when both USB disk and NVMe are connected.

HI KevinFFF:
My build environment is Ubuntu18.04,I hava a problem when I build it without docker.
When I install edk2-pytool-extensions,it still reports error below: