Boot problem on live device


I have seen some similar topics about my problem which are automatically closed although the problem is stated clearly and not solved.

I have a Jetson Xavier NX device and the device is live meaning it has an environment inside with working code.

The problem is if the ethernet cable is attached to the device, it writes at the beginning “Test key is used” and tries to boot from network. It takes 2-5 minutes of time. I tried to go to boot menu and wanted to change the boot order. In the menu it says “press Enter to select the boot option and use the arrow keys to set the order”. When I press enter on the boot option (I have nvme hard drive on this device), it starts from that option, which is NVME and overall the system DOES NOT allow me to change the boot order.

Is there any way to do that without flashing the whole device? I cannot wipe the device now.

I would be grateful if you have an idea.

System information:

xavier@xavier:~$ uname -a

Linux xavier 5.10.104-tegra #1 SMP PREEMPT Wed Aug 10 20:17:07 PDT 2022 aarch64 aarch64 aarch64 GNU/Linux

xavier@xavier:~$ cat /etc/os-release

VERSION=“20.04.5 LTS (Focal Fossa)”
PRETTY_NAME=“Ubuntu 20.04.5 LTS”
BUG_REPORT_URL=“Bugs : Ubuntu
PRIVACY_POLICY_URL=“Data privacy | Ubuntu


I doubt I can solve this, but can you provide a full serial console boot log for two cases:

  • Without ethernet, such that it boots normally.
  • With ethernet, such that it tries to network boot.

Perhaps it is just something simple such as reordering boot entries.

Hi safa,

Are you using the devkit or custom board?
What’'s the Jetpack version in use?
Please help to provide the following result

$ cat /etc/nv_tegra_release

So, could you change the boot order in the boot menu of UEFI?
You might need to change boot order → Save → Exit.

and We need the serial console log to know more about your board.

@ linuxdev Can you tell me how can I get the console boot log?

As I stated it does NOT allow me to change the boot order. When I select NVME in the boot menu by pressing enter, it boots from that part immediately. I can not select.

I will post the logs and release soon.

Here’s something a bit longer regarding serial console:

The gist is that you use a micro-B USB cable from the Jetson to a host PC. Then you attach to the device which shows up (typically “/dev/ttyACM0”) at speed 115200, 8 bits, no parity, and 1 stop bit (115200 8N1). I like gtkterm as a serial console program (“sudo apt-get install gtkterm”). That other URL mentions using that for connecting.

The serial console program will allow you to clear the screen (if you’ve been booting for test), start logging, and then when you turn on the Jetson it should log everything. The log will be on the host PC and you can attach it to the forum.

I’ve just verified on the devkit for changing boot order.
I think you might not use “-” to change boot order.

The overall steps to change boot order in UEFI is as following:

Step 1: Enter Boot Menu
When you see the NVIDIA logo at boot up, Press "ESC" to enter setup.

Step 2: Change Boot Order
Boot Maintenance Manager -> Boot Options -> Change Boot Order -> Press "Enter" and a prompt showed up -> Press "-" to Move Selection Down -> Press "Enter" and the prompt vanish

Step 3: Save and Exit
Press "F10" to Save -> Press "Y" to Confirm -> Press "ESC" 3 times back to Boot Menu -> Select "Reset" and Press "Enter"

If you still have problem about changing boot order, please provide the serial console log and also the screenshot of boot order menu for further check.

ok I found that I am using the wrong menu. I was using boot manager not boot maintenance manager.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.