Unable to flash Orin NX to boot from USB SSD

  • Orin NX 16GB (P3767)
  • Custom Carrier Board, used successfully with Xavier NX (Auvidea JNX30D)
  • USB SSD 128GB formatted as ext4, single “App” partition.
  • JetPack 5.1.1, hence R35.3.1
    SDKManager fails to recognise that the board is connected despite lsusb showing the correct ID 0955:7323. So, having collated tips from various other posts I put together the following command sequence:
tar xf Jetson_Linux_R35.3.1_aarch64.tbz2
sudo tar xpf Tegra_Linux_Sample-Root-Filesystem_R35.3.1_aarch64.tbz2 -C Linux_for_Tegra/rootfs/
cd Linux_for_Tegra
sudo ./apply_binaries.sh
sudo ./tools/l4t_flash_prerequisites.sh

edit “Linux_for_Tegra/bootloader/t186ref/BCT/tegra234-mb2-bct-misc-p3767-0000.dts” for
“cvb_eeprom_read_size = <0x0>”
as per Problem flashing ORIN NX

sudo ADDITIONAL_DTB_OVERLAY_OPT=“BootOrderUsb.dtbo” ./tools/kernel_flash/l4t_initrd_flash.sh --no-flash --external-device sda1 -c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml” --showlogs --network usb0 p3509-a02+p3767-0000 internal

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --erase-all --flash-only --showlogs p3509-a02+p3767-0000 sda1

The build completes OK, the board is found but the flashing fails as it appears to be trying to use emmc which does not exist on Orin NX.

Waiting for target to boot-up...
Waiting for device to expose ssh ......RTNETLINK answers: File exists
RTNETLINK answers: File exists
Waiting for device to expose ssh ...Run command: flash on fc00:1:1:0::2
SSH ready
blockdev: cannot open /dev/mmcblk0boot0: No such file or directory
[ 0]: l4t_flash_from_kernel: Starting to create gpt for emmc
Active index file is /mnt/internal/flash.idx
Number of lines is 75
writing item=59, 6:0:primary_gpt, 512, 19968, gpt_primary_6_0.bin, 16896, fixed-<reserved>-0, 8cf4a12a3c503a647a6c3140c742931d87aeb94c
Error: Could not stat device /dev/mmcblk0 - No such file or directory.
Flash failure

I have tried using a 128GB USB flash drive instead of the SSD with the same result.

Any suggestions on what further needs editing for this situation?
flash_3-2_0_20230405-172156.log (6.9 KB)

Hi robotmad,

Does your custom board design based on Xavier NX carrier board(p3509)?

It seems mmcblk0 has been specified somewhere (which is used for eMMC or SD Card).

Please try the following command for USB flash drive:

$sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device sda1 -c tools/kernel_flash/flash_l4t_external.xml \
-p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" --showlogs --network usb0 p3509-a02+p3767-0000 internal

Or the following command for NVMe SSD:

$sudo ADDITIONAL_DTB_OVERLAY_OPT="BootOrderNvme.dtbo" ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 \
-c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
--showlogs --network usb0 p3509-a02+p3767-0000 internal

Thanks Kevin. Using your command for USB flash drive I get exactly the same result and the same Error.

Which type of log file(s) would be the most help please?

How about the NVMe SSD? Have you also tried to connect an NVMe drive and flash with above command?

Please provide the flash log from host PC and serial console log of the board during flash.

Apologies for the delay - I needed to purchase a specific connector in order to log the serial console.

Unfortunately I don’t have an NVMe SSD in this setup.

Logs now attached.

flash_3-3_0_20230414-174949.log (6.9 KB)

orin_nx_serial_console_log_jetpack_5_1_1_installation_failure.txt (116.3 KB)

Error: Could not stat device /dev/mmcblk0 - No such file or directory.

What is your current flash command in use?

This is using the command you suggested on 6th April for install onto USB flash drive:

Is there a different command worth trying?

Are you using custom JP5.1.1 BSP package to flash?

Is that work?
If not, please provide the flash log for further check.

I am using the standard Nvidia JP5.1.1 Orin NX package, nothing customised.
Flash log attached to post on 14th April - if this isn’t what you are looking for please clarify what log is required.

Many thanks

Do you have other usb drive or ubuntu host machines to test?

The error log seems weird.

Are you sure the flash command is:

I’ve tried two different USB drives already - will try to borrow an alternative host machine to test with.

Since this is custom board, are you sure our default BSP/flash command can flash this board? Maybe you should check with the board vendor if special BSP is required.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.