How to set PowerMizer to "Prefer Maximum Performance" in .nvidia-settings-rc ?


First, sorry for my bad english, i’m french.

I have a problem to set PowerMizer to “Prefer Maximum Performance” in the file “.nvidia-settings-rc”.
Whether I put “Prefer Maximum Performance” or “adaptive”, nothing changes in the .nvidia-settings-rc file when i save it.

I have the bumblebee driver because i have two gpu, one Intel and one Nvidia.

If you need other information to solve the problem, ask to me.


I almost forgot:

I play mostly with the game “csgo” with Steam application. But I have a problem of falling fps with it. In some places of some maps I go down to about 19fps.
The big difference with the Intel driver is the home screen (the panoramaui) where I have 30fps with the Intel driver and 60fps with the driver Nvidia.
And the “training mode” which is absolutely unplayable with the Intel driver (less than 9fps) and I go up to 60fps with the driver Nvidia, so totally playable (So the Nvidia driver works with my system, 100% sure, but i do not understand this fall of fps to 19 in some maps of csgo).

I start the game by go to the properties of csgo and put “vblank_mode=0 primusrun %command%”.It’s the only solution that’s work.
"optirun %command% dont work (the game dont start), and “optirun steam” give me this error “Failed to create SDL window: Couldn’t find matching GLX visual” (work only with “half-life 2”, but without an augmentation of fps).

Why do I have a fall of fps in some maps of csgo? (as with the Intel driver, but less)
And how to set PowerMizer to “Prefer Maximum Performance” in the file “.nvidia-settings-rc” ?

This is my two questions.

Thx !

I forgot, I also have this error in my terminal when I run nvidia-settings:

And my file .nvidia-settings-rc:

No one to help me ?

Help me please…

I do not want to edit the .nvidia-settings-rc file myself. Because I’m afraid to damage my graphics card.


I don’t think that’s ever saved in .nvidia-settings-rc
You should have used the forum search:

Thx for your answer but this command dont work for me:

When i restart nvidia-settings, the parameter powermizer is always on “auto”, with “adaptive” written in “current mode”

Yet, this command is editable:

I will try to edit my /etc/bumblebee/nvidia.xorg.conf
But, can you give me the good command for this two parameters:

  • GPUPowerMizerMode (to high performance)
  • OpenGLImageSettings (to high performance)

I havent found anything by a search on the forum…(Except for GPUPowerMizerMode, but it’s not clear for me, because it’s not written like this > GPUPowerMizerMode, but like this > PowerMizerEnable=0x1, in this topic:

Other question, when i start csgo, i have always one core who is at 100% of use.
Do you know what is the problem ?
It’s could be a problem with the Nvidia driver ?

If you use bumblebee and run

optirun nvidia-settings -c :8 -a '[gpu:0]/GPUPowerMizerMode=1'

bumblebee will start an Xserver, run the setting and the stop the Xserver afterwards, thus resetting it.
Bumblebee has a setting though that keeps the Xserver alive, don’t know the exact name, like ‘NoKillUnusedX’
This should let the settings you apply through nvidia-settings survive.
The syntax for the xorg.conf to make the PowerMizer setting permanent is correct, it differs from the nvidia-settings syntax. I don’t think there’s an xorg.conf setting for OpenGLImageSettings.
BTW, please don’t create such massive walls of test, attach long outputs as file. Hovering the mouse over an existing post will reveal a paperclip icon.

maybe something like this would also work:

optirun sh -c "nvidia-settings  -a '[gpu:0]/GPUPowerMizerMode=1' && nvidia-settings"

Edit: max not auto


This command dont work:

Or this one:

Yeah, forgot about the display, try this:

optirun sh -c "nvidia-settings -c :8 -a '[gpu:0]/GPUPowerMizerMode=1' && nvidia-settings -c :8"

Yes it’s work. Thx