Powermizer "Powersave" configuration not working any more

Hi! I made a new install of Ubuntu 18.04 on my system with a GTX 1060 + Intel.

I followed the steps of

to set perfomance to the lowest value but this is not working any more. The Powermizer RegistryDwords seem to be ignored. Options like “Coolbits” are recognized in the xorg.conf.

NVIDIA X Server Settings tells me that I am on level 4 most of the time and thus fans are spinning constantly.

Any recommends? What logs do you need?

driver: 390.77


Thing to try:

Thanks for the quick answer!

First, I updated to the 390.87 driver, which was available via Ubuntu updater today. There is no change. Then, I upgraded with the ppa:graphics-drivers/ppa to the 410 driver, but also no change.

So I have still no possibility to set RegistryDwords options in the xorg.conf.

I can’t really follow your plan with the OverrideMaxPerf from the link. What value should I set and where? In the other thread it is done via kernel module options. Where exactly do I set those in Ubuntu 18.04.1? I’ve never done this before.

In Debian (where it worked flawlessly) I used kernel 4.17. I’ll try to upgrade to this. Maybe the 4.15 from Ubuntu is too old.


The registrydwords can be either set in xorg.conf or like the user from that thread used, in a file in /etc/modprobe.d, eg /etc/modprobe.d/99-nvidia-registry.conf

options nvidia NVreg_RegistryDwords="OverrideMaxPerf=0x1"

and run
sudo update-initramfs -u
then reboot.

Hi generix!

That did the trick! Thank you very much for the detailed description.

I saved the option in /etc/modprobe.d/99-nvidia-registry.conf and now Performance Level stays at zero :)