Powermizer different behavior using X and Wayland RTX 2080 SUPER

I have been reading though the forums looking for a solution for GPU high idle power draw. I.e. performance level keeps at 4 (nvidia-smi P0).

According to this and this threads, utilizing RegistryDwords should set desired performance level. I have added Option “RegistryDwords” “PowerMizerEnable=0x1; PerfLevelSrc=0x3333” to /etc/X11/xorg.conf.d/20-nvidia.conf, but nothing has changed. I have tried numerous variations. And so I dug deeper.

Things get interesting when working on Wayland. Obviously, nvidia-settings doesn’t work, but nvidia-smi shows that performance level is P8 when idle and Powermizer works just fine, i.e. levels change depending on load. Power draw is lower and so is the temperature.
The question is, how can I configure nvidia-settings or Xorg in order to make it work? Wayland is still a bit glitchy using proprietary drivers.

nvidia-bug-report.log.gz (251.2 KB)

“PowerMizerEnable=0x1; PerfLevelSrc=0x3333”
you’re basically only setting the default, adaptive performance level for both AC and battery.
The deeper issue is a known bug in the nvidia driver when Xorg drives two or more monitors with a higher reolution than HD. It’s then always running at P0, highest performance state.

Thanks for the reply.
From what I could gather, for drivers >v460 there is no way to override this. Neither with xorg.conf nor kernel modules, nor nvidia-settings.
What is interesting, though, running on Wayland, levels are dynamic. In other words, they vary based on current load (P8 in idle, P0 under load). Wayland uses Nvidia drivers too. Having said that, perpahs there is a way to adapt this behavior in X.