Pinning PerformanceLevel through RegistryDwords forces highest PLevel (since driver 334.xx upwards)


Since the adaptive PowerMizer is not sensitive enough with upping the Performance Level and P0 reveals visible slow repaint in some GTK+ programs, I used to pin the level to P1 which was enough for my day to day use.

Since 334.xx (including 337.xx) though, this no longer works and always forces the card to its maximum performance level. Uncommenting the respective line from Xorg.conf and restarting X does not always work to restore at least the adaptive behavior. Usually you have to do a unload/load cycle for the nvidia blob as well.

I know this is an unsupported feature but it is the only way to force a PLevel. And since one cannot influence the sensitivity of the PowerMizer adaptive governor, this seems to be the only solution to fix slow repaints and make the card usable for work.

Forcing MaxPerformance is really no solution since it unnecessarily burns power. And even though the new Overclocking feature can be used to underclock the card, there is no way to persist the settings. Besides, forcing MaxPerformance while underclocking to a P1 alike setting, seems to still heat up the card pretty good.

It would be nice if this feature could be fixed. :)

Thanks a lot in advance.

So long,
nvidia-bug-report.log.gz (108 KB)


This is still an issue w/ 337.19. :(