How to set prime-select back to nvidia?

I’m using a Thinkpad with a GeForce RTX 2070 Super Max-Q and two external Screens and Ubuntu 22.04. prime-select was set to on-demand before.

Then I went travelling and called sudo prime-select intel in order to disable the nvidia card to save power / heat. Everything was good.

Then, back at home, I want to make everything as before, so I wanted to enter prime select on-demand (or prime-select nvidia, whatever, I dont care), because thats the only valid way a switch is supposed to work.
What happens? Error: no integrated GPU detected.
WTF? Look inside. There is one, because I’ve used it before. Look harder. Undo everything you did. Its your job, not mine.

The laptop was not so cooperative answering me, so I after some research (thanks Google for showing me results from like 1978 when searching for the most current solution for a technical problem), I found a /lib/modprobe.d/blacklist-nvidia.conf and deleted it (I wanted to disable nvidia temporarily, not extinguish it from existence), followed by some ceremonial commands like modprobe nvidia and sudo update-initramfs -u. Maybe I did something incantation with bbswitch, I dont remember.

Now can use all three screens again and nvidia-smi shows something. I could now be happy and call it a day, but as a software engineer I want to be sure, that under the hood everything is back to normal.

sudo prime-select on-demand" continues to say “Error: no integrated GPU detected.”. Srsly, what the fuck? It’s supposed to work now.
How can be sure, that it’s exactly the way it was before? What is still missing? What kind of hidden thing did that very first command, that I have to revert? Why is it so hard to do such a simple task?

The message usually is displayed when trying to use prime-select on nvidia-only notebooks, i.e. there’s no igpu (intel/amd) detected.
Also, prime-select intel is not necessary anymore on modern notebooks, in on-demand mode the nvidia gpu will auto-poweroff when not used.
Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Thanks for answering so quickly, here you are:

nvidia-bug-report.log.gz (424.1 KB)

Seems you have set your notebook to nvidia-only in bios. Please switch back to hybrid mode.