prime-select query unknown, can't switch anymore

I’ve updated to kernel 4.5 and nvidia-361 today, to see if the new patches regarding vsync issues are there already.

But after the update I can’t even switch anymore:

sudo prime-select nvidia
Error: alternatives are not set up properly
Error: nvidia mode can't be enabled
prime-select query
update-alternatives --list i386-linux-gnu_gl_conf

When I use the nvidia settings tool, it seems that intel is enabled, but when I switch to nvidia, I get an error dialog without any actuall error message (just a red exclamation mark).

Tried various solutions from the web, including purging / reinstalling the drivers. Nothing worked.

Any help would be appreciated!

EDIT: Maybe that is of use?

sudo nvidia-settings 
** Message: PRIME: Requires offloading                                                                               
** Message: PRIME: is it supported? yes                                                                              
ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with this
       driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will
       continue to work, but values cannot be prepopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

EDIT 2: I’m on Kubuntu 14.04 LTS 64bit, ACER V3-772 Laptop with Geforce 750m and i5-4200m

EDIT 3: I rolled back to 358, but the issue remains. Seems to be kernel related…

So 364.12 shipped tonight to my distro. I got it installed and running now, but I’m still stuck on the previous issue.

Can please anyone help? I really want the new VSYNC option and have finally everything running as it should! What am I supposed to do?

sudo update-alternatives --remove i386-linux-gnu_gl_conf /usr/lib/i386-linux-gnu/mesa/
sudo update-alternatives --remove x86_64-linux-gnu_gl_conf /usr/lib/x86_64-linux-gnu/mesa/

By removing these mesa settings I’m able to switch again! But now when I’m on nvidia and try to launch Steam, I get “opengl extension not supported by display”. When I switch back to intel I can launch Steam. Again, been diggin through pages of forum posts and tried everything like reinstalling mesa-utils etc, without exactly knowing what I’m doing. It doesn’t work, and also I still have lots of tearing on nvidia e.g. when watching a video. (Which kinda was the whole point of this action)


Hi frMage,

I have the exact same problem that you described.
Can you help me out and tell me if you got around this eventually?
Any help would be much appreciated!

Sorry man, after this event I was unable to recover this system in it’s full. I had invested a lot of time in customizing this linux laptop, making my own scripts, fiddeling with drivers etc. I waited for some time to get support from Nvidia or an updated driver but eventually gave up and sold the laptop. Don’t have time for this anymore.

Your best bet from my point of view: Give up here, reinstall, once things are smooth, take a complete backup. Linux & Nvidia drivers ain’t in the state I wish they were.

Oh no that sounds like you have given up!

Too bad Nvidia is not really supporting Linux users…

Thanks for your insights though! I haven’t given up yet.

Nvidia is only providing the binary driver, the prime switching infrastructure is developed by Ubuntu. So it should be obvious that Nvidia is not supporting that since they didn’t make it.
It consists of

  1. the ogl drivers
  2. switching infrastructure packages
  3. the update-alternatives system

So you should purge/clean those and reinstall them.