Nvidia Prime stopped working after upgrading to 390.48

Nvidia X Server Settings is disappeared from taskbar.

** Message: PRIME: Requires offloading
** Message: PRIME: is it supported? yes

So i can’t switch back to Intel.

Is there any fix coming to it?

dpkg -l | egrep 'nvidia|bumblebee|primus|prime|virtualglrx'
ii  nvidia-390                                                  390.48-0ubuntu0~gpu16.04.2                                   amd64        NVIDIA binary driver - version 390.48
ii  nvidia-390-dev                                              390.48-0ubuntu0~gpu16.04.2                                   amd64        NVIDIA binary Xorg driver development files
ii  nvidia-prime                                                0.8.2linuxmint1                                              amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                                             396.18-0ubuntu0~gpu16.04.1                                   amd64        Tool for configuring the NVIDIA graphics driver

nvidia-bug-report.log.gz (91.5 KB)
gpu-manager.log (2.71 KB)


What exactly is broken, can you still use sudo prime-select query/intel/nvidia? What kind of ‘Nvidia X server settings’ are you talking of, some kind of panel applet?
You have the 390 driver installed but the 396 nvidia-settings, maybe do another upgrade to get the matching driver.

I’m in similar boat but much worse. I can’t even boot up properly since the upgrade.

I think the version of nvidia-settings could be causing problems. How can I install nvidia-settings version 390?

Specifically nvidia-settings 390.25-0ubuntu0~gpu14.04.1

Problem is , Nvidia Settings applet disappeared. And somewhat Prime is not recognizing my Intel card and blocks switching to it. Even terminal way ( sudo prime-select intel ) is not working.

So how can i get that specific Nvidia 390.48 settings?

Looks like the 390 Version of nvidia-settings has been removed from ubuntu repositories. But this shouldn’t keep prime-select from working.Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Also attach /var/log/gpu-manager.log

Requested files attached.

Ok, that looks like a regular start while switched to nvidia. What’s the output of
sudo prime-select query
sudo prime-select intel

sudo prime-select query
sudo prime-select intel
Info: the current GL alternatives in use are: ['nvidia-390', 'nvidia-390']
Info: the current EGL alternatives in use are: ['nvidia-390', 'nvidia-390']
Info: selecting nvidia-390-prime for the intel profile
update-alternatives: /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) alternatifini sağlaması için /usr/lib/nvidia-390-prime/ld.so.conf elle ayarlanmış kipte kullanılıyor
update-alternatives: /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf (x86_64-linux-gnu_egl_conf) alternatifini sağlaması için /usr/lib/nvidia-390-prime/ld.so.conf elle ayarlanmış kipte kullanılıyor
update-alternatives: /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) alternatifini sağlaması için /usr/lib/nvidia-390-prime/alt_ld.so.conf elle ayarlanmış kipte kullanılıyor
update-alternatives: /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf (i386-linux-gnu_egl_conf) alternatifini sağlaması için /usr/lib/nvidia-390-prime/alt_ld.so.conf elle ayarlanmış kipte kullanılıyor

alternatifini sağlaması için : to provide alternative

elle ayarlanmış kipte kullanıyor: it is running with manually provided config

Looks perfectly normal.
After running
sudo prime-select intel
What’s the output of
sudo prime-select query
after reboot?

sudo prime-select query

Thing is i’m scared to reboot at this state , i don’t want to fall into black screen.

Is it possible to culprit here is modeset?

sudo xed /etc/modprobe.d/zz-nvidia-modeset.conf

options nvidia-390_drm modeset=1

I’m using like that to use PrimeSync.

Also as a not but probably irrelevant ; i have acpi windows 2009 variable on grub.

Both should be fine.
So it’s crashing if you boot to intel? Then the relevant logs would be from that state. Can you switch to VT using ctrl+alt+f1? Can you ssh in from another system?

If i select intel and reboot with that , it just stays with a blinking command prompt pointer. After a time waiting like that , fans ramps up. It is a very similar behaviour when i didn’t set acpi variable.

Ctrl+alt+F1 was unresponsive at that state iirc.

That’s odd, then. Did you do a bios upgrade recently that could have triggered this, or just a driver and/or kernel update? Though the driver shouldn’t be loaded while switched to intel anyway.

No , i didn’t update my bios. I just upgraded from 390.25 to 390.48. That’s all.

390.25 was bad , it had a problem with Darkest Dungeon. Hovering mouse on trinkets to see stats of them would crash the game on 390.25 but it got fixed on 390.48.

Looks like you can only ssh into your frozen box to see what’s going on, then.
Did you patch the 390.25 driver to work with kernel 4.15 or did you use another kernel? If so, maybe see if using the previous kernel works around the issue.

Kernel is the same one i used with 390.25.