How to set up Jetson board to boot automatically when power applied?

Hello all,
I have 2 Jetson TK1 boards. One of them boots automatically when I plug in the DC supply, the other does not. Can anybody tell me how to configure the board so that it boots automatically when power is applied?



Both should boot automatically. The method of disconnecting power may leave partial power on one which would be an issue. Pulling the plug from the wall would leave capacitors powering for a moment…disconnect from the Jetson at the connector on the board would be a complete power down. None of this is good for Jetson, it is a computer with surge protection issues like any other. The big question is what would you like to accomplish?

I would like the board to boot when power is applied. Right now, it doesn’t. After applying power, I have to press the “POWER” button on the 2nd board in order for the LEDs to come on, the fan to spin, and the processor to start booting.

That is not the case on the first board.

I agree, pulling the power cord arbitrarily is not the right thing for the filesystems. Eventually (hopefully shortly) I will replace the R/W filesystems with RO filesystems to address that.

But, in the short term, I need 2 boards that both boot on powerup.

What you describe seems to be a hardware issue…even if you flashed it with different boot loaders and such, the LEDs and fan spin should not be affected…this is prior to boot loader. Both boards should simply boot upon applying power…the one that does is working. I would check on RMA for the one that fails.

My board also does not boot/power when power is applied. I also have to press power button to start it. It started to behave like this a while ago.

I made it to get my board to boot when power cord is plugged in. I simply disconnected everything from the board for 2 hours. Now it works as advertised.

Does it work now even if you leave things plugged in?

damn, nope it is not booting now when unplug/plug, I have to press power to boot it. Is it faulty ? Beat me… everything works well (touch the wood) except that power plug issue. So I will forget about it.

Have you tried powering them with a Lab DC Power Supply?

The one you can set the Volt and Amp but doesn’t supply until the supply button is pressed.

Check the external components. I would not be surprised if one of them is back-feeding power to the board. This might be locking something up and causing an issue. This is a BAD thing to do in general, it has a tendency to destroy electronics.

with nothing connected to the board - even fan disconnected, the board behaves the same. unplug/plug no boot. leave it for 1hour without power - it will boot once when cord is plugged in.

I guess the only way to properly fix the “automated power on” is to use something external (e.g. a microcontroller) on the expansion header that turns on the Jetson after itself has been powered. Very inconvenient, I know…

I will leave it as is with this board. This particular board will become media player and this failure to boot on power plug will become feature.

Please try removing 0.014F capacitor (C6D4 part) on PMIC’s VBAT_BKUP pin on Jetson if you have a soldering iron.

Basically the 0.014F capacitor is keeping +2.5V_AON_RTC signal high for hours to keep PMIC’s AC_OK (pin to indicate that the AC adaptor is present) high when cord is plugged out.

Removing the capacitor help PMIC to recognize AC adaptor plug out soon and plug in the cord shortly after plug out will make PMIC to initiate power up cycle automatically.

Thanks for suggestion youngk, however I think I would make more damage than good. Soldering iron in my hands is lethal weapon for electronics :)

That’s what I wanted to suggest. Use a cheap 8 pin microcontroller and bypass this issue.

Thanks for the Info. I was thinking using a microcontroller to handle it once I get around to it.

I’ve noticed an interesting thing. After uploading L4T 21.x - well I did not start when inserting the plug. Today I went back to L4T 19.3 and works again :)

U-boot was modified from R19.x I think…perhaps something in pre-boot environment? Still, this shouldn’t happen.

:| Santiago, I have noticed that too… I know it shouldn’t matter but it simply works OK since I rolled back to 19.3…