How to setup USB config#4 for TX2 l4t 28.2.1?

Hi all,

We made a customed carrier board which has two USB3.0 port.

  1. F43, F44, C43, C44
    A38, A39, A18

  2. G42, G43, D42, D43
    B42, B43, A19

But after trying [url]Jetson/TX2 USB - and [url][/url]

I can only get the first one(F43, F44, C43, C44, A38, A39, A18) work. Another one is not working.

I modified 3 files,

  1. p2771-0000.conf.common

  2. tegra186-quill-p3310-1000-a00-plugin-manager.dtsi


I put them on google drive with lsusb -t result and hardware schematics.

[url]2usb - Google Drive

anyone can help?

Per oem design guide:
A19 is not in use. You may re-work HW and use another pin as VBUS pin.

Please also notice that VBUS cannot be turned on too early:

Hi DaneLLL,

I don’t understand why A19 is not in use. B42 and B43 are data pins of USB2, and A19 is USB2_EN_OC.

If A19 is not in use, which pin should I use, and how to modify dts files?


Please check Figure 15 and Table 93 in oem design guide. A19 is RSVD.

You need to re-work the board to connect to other pin.

Hi DaneLLL,

I connect a 5V to USB VBUS pin directly.

Like this picture:

But (G42, G43, D42, D43, B42, B43) still not working.

For SW device tree, you can refer to

devmem2 is to check if odmdata is correct.
xxd is to check if xhci@3530000/phy-names, pinctrl@3520000/pinmux/usb2-2(and usb3-2) are correct.

IF above check is good, t is more like an issue in HW and you can check if VBUS is on too early.


Some update, I use another carrier board and connect 5V to the second USB port(G42, G43, D42, D43, B42, B4).

It works now!


@ShayWang I’ve met the same issue, you mentioned " I use another carrier board and connect 5V to the second USB port(G42, G43, D42, D43, B42, B4).", so you used pin B4 to be as VBUS 5V enable? Thanks for your information?
@DaneLLL Would you please suggest which pin to replace A19 as the VBUS enable pin? Thanks a lot.

Please refer to product design guide:

We would suggest use load switch and either GPIO pin to enable 5V power to the USB port.