How to tracks only secondary nvinfer objects in deepstream

• Hardware Platform (Jetson / GPU) : Both
• DeepStream Version : 5.1
• JetPack Version (valid for Jetson only) : 4.5
• TensorRT Version : 7.1.x

I created a pipeline that has three main elements:

streammux >> pgis >> sgie >> tracker(iou) >> …

The sgie is detector. My problem is that I want the tacker only tracks the sgie objects. How I can handle this problem?

Please check this,
Track on the specified class-id - Intelligent Video Analytics / DeepStream SDK - NVIDIA Developer Forums

@Amycao ,
This is filter out on some class id to skip that class-id for pushing objects metadata to upstream element(tracker), but my purpose is difference from that,
I have pgie followed by sgie and then tracker, but the tracker see both objects of pgie and sgie, and tackers both objects, but I want to tracks only sgie objects.

You can skip all pgie class id objects.

How? If I do this way, So the sgie has’t any objects to inference, right?
The best way is that the tracker should to has same options config file like pgie and sgie, then we set the objects with unique component id for skipping, or the tracker should to has same property of pgie and sgie like this:

Tracking objects only on given ID is already a part of our feature roadmap for future release.