How to use rtsp feed with deepstream-test4-app?

i am not able to find a way to feed deepstream-test4-app with live camera feed. Is their any example available from where i can refer.

Hi shivamg1mnk,

There is no example available now, we will enhance test 4 app to allow RTSP input in coming release.


Test 4 source is filesrc. You can replace it by uridecodebin in test 4 as a source input and provide RTSP URL link.
OR Refer to deepStream-app or Test 5 app for a comprehensive RTSP input source configuration - "sources/apps/sample_apps/deepstream-test5 "

dp4 now supprt this condition?---- live streaming by rtsp server,if yes, can u show a example

what is dp4? I think comment #3 is very clear for how to input RTSP stream in your pipeline.


after referring to comment #3 to run test1 with rtsp as follows:

source = gst_element_factory_make ("uridecodebin", "file-source");

i received the following error:

(deepstream-test1-app:18809): GLib-GObject-WARNING **: 11:21:38.563: g_object_set_is_valid_property: object class 'GstURIDecodeBin' has no property named 'location'

this is the command i issue:

./deepstream-test1-app rtsp://admin:admin@

device: jetson TX2

i have solved the previous issue with changing line 224 in deepstream_test1_app.c from :

g_object_set (G_OBJECT (source), "location", argv[1], NULL); --> g_object_set (G_OBJECT (source), "uri", argv[1], NULL);

but now i have this error:

Elements could not be linked: 1. Exiting.

Could you help to set the GST_DEBUG=3 and capture more log?

where do i set GST_DEBUG to 3 ?

I have this error when i use test4 input rtsp stream
bash: rtsp://admin:123456@ No such file or directory

Could you create a new topic for you issues, thanks!

Hi, I got the same error as the uridecodebin can’t be link, is there any example of this?