How to use xconfig?

I am using TX2 and JetPack 4.3Ver, I want to use xconfig here.

However, the following message is output. “make: *** No rule to make target’xconfig’. Stop.”.

So the following method was used, but it was not solved.
$ sudo apt-get update
$sudo apt-get install qt5-default.

What is the solution?


It is hard to understand what you are trying to ask. Please do elaborate your problem.
Are you trying to install Qt but cannot compile?

Are you talking about configuration using xconfig to build Qt5 from source? I know about “nvidia-xconfig”, but this is from a desktop PC, I don’t know if that exists in the embedded world or not. Other xconfig applications might be provided by Qt for their software, not sure.

Not sure, but in case you mean configuring kernel with make xconfig, it may depend on Qt4.
You may try:

sudo apt-get install libqt4-dev pkg-config

Note that you can altenatively install ncurses and use make nconfig instead.

First of all, I am Korean and I don’t speak English well.
So the sentence is strange. I am not sure how to write.
Thanks for answering my question.

You are right.
I was talking about Qt5. I also tried to change kernel options using xconfig.
Thank you for giving me the information.

okay. I will try with your information. Thank you.

I may help you to know that what any xconfig does is to provide configuration parameters for software builds against that particular X server. Qt may need different parameters than does a program build some older/different interface.

The xconfig which may arrive in some basic form with X could work for many different software compile requirements, but Qt and some other software may provide their own version of this. Thus this is the reason why the xconfig you need is probably provided by Qt.

You might want to try Google Translate if you find language barriers. This works for English to Korean or Korean to English.
영어에서 한국어로 또는 한국어에서 영어로 작동하는 Google 번역을 사용해 볼 수 있습니다.