How to Visualizing the Retraining with TensorBoard

Hello,
I’m using Nvidia Jetson Tx2 with Ubuntu 16.04, TensorFlow, CUDA9.0 and Cudnn 7.7.
I retrain image with this document: https://www.tensorflow.org/hub/tutorials/image_retrainin but I don’t understand how to Visualizing the Rẻtaining with TensorBoard.
tensorboard --logdir /tmp/retrain_logs I can’t use that cmd.
Please help me.
Thank you

The NVIDIA TX2 is mainly an inference machine, which means you are not expected to be able to quickly train networks on it. It is instead used at inference time to deploy trained models; trained on more capable systems such as a desktop or server grade GPU machines.

That said, if you are able to successfully run your Tensorflow training code, I’m not sure why you’re having trouble with Tensorboard. Can you post the error messages?

Hi,

As singularity7 said, it’s NOT recommended to use Jetson for inference training.

If you can launch tensorboard successfully, the visualizing graph can be found at the port 6006:
Ex. http://127.0.0.1:6006/

Thanks.

Hello singularity7,
Thanks for your response.
As I said, that I use this document: https://www.tensorflow.org/hub/tutorials/image_retraining to retrain image.
But when I work in tensorboard with this terminal: tensorboard --logdir /tmp/retrain_logs
so that is my error:

https://www.upsieutoc.com/image/tensorboard.GQB1EM
Can you help me?
IF It’s NOT recommended to use Jetson for inference so how to retrain image by tensorflow?
Thank you!

Hi,

Sorry for my typo. I means Jetson is designed for inference, not good for training. (update comment#3)

From your log, there is no tensorboard executable on your environment.

-bash: tensorboard: command not found

How do you install TensorFlow package? It looks like you don’t include tensorboard package.

You can try our official TensorFlow package.
tensorboard binary will be automatically installed from this package:
https://devtalk.nvidia.com/default/topic/1038957/jetson-tx2/tensorflow-for-jetson-tx2-/post/5278617/#5278617

Thanks.

Hi AastaLLL,
Thanks for your response,
Yeah, I installed TensorFlow with your package: pip install --extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu

So how to check tensorboard version on my TensorFLow? And do you know anyway to install TensorBoard?

Hi,
i imported tensorboard. But when I run it in my environment so have this error:


Messenger show: NameError: name ‘logdir’ is not defined
What is this failure?

You are running that command inside your python shell.

You need to be running it from the bash terminal.

USAGE:

Your script will generate some folder of log information, defaults to “runs”, I believe.

So from your terminal, you can type the following command

tensorboard --logdir /path/to/runs

or in your case

tensorboard --logdir /tmp/retrain_logs

Hi singularity7,
thanks for your response,
I tried running that command inside my python shell and bash terminal. In the bash terminal so the error messenger show is: “bash: tensorboard: command not found”
I think failure is We don’t have any environment for python, tensorflow and tensorboard.

Hi ,
i am also having the same problem with running tensorboard in TX2 . i followed the same installation

pip3 install --extra-index-url=https://developer.download.nvidia.com/compute/redist/jp33 tensorflow-gpu
nvidia@tegra-ubuntu:~/.local/lib/python3.5/site-packages/tensorboard$ tensorboard --helpfull
bash: tensorboard: command not found

has anyone solved this issue

Hi,

It looks like you already have tensorboard installed.
Would you like to try the steps mentioned here:
https://stackoverflow.com/questions/45095820/tensorboard-command-not-found

1. Enter the tensorboard folder

2. Launch it with main.py

python main.py --logdir=/path/to/log_file/

Thanks.