HP RGS Xorg Configuration

I am trying to do a GPU pass-through to a Linux VM using one of my K1 cores. The pass-though works fine, but I’m using HP RGS and I can’t get X to start in a headless configuration (which obviously this has to be) if I load the nVidia driver. Does anybody who has HP RGS working on Linux have a suggestion…at least for a manual I can go an read?

Hmm … well I just spent a bunch of time posting a reply, and my post disappeared. Testing a simple reply first before I wasted a bunch of time again with this crippled tool.

OK … trying again, more brief than previous attempt …

www.hp.com/go/rgs has a white paper, gist of the title is "RGS in the Datacenter", and this has some context/background of how to get RGS going in general in headless physical or virtual setups.

What follows is an example xorg.conf for RHEL6.5-ish VMs, specifically for K2, dual-display setup, and HP Z30i display. Since I cannot attached EDID file here, you can capture one yourself using NVidia Control Panel (Windows) or NVidia-settings (Linux) on non-virtual setup – either .bin or .txt format EDID files are acceptable. If you don’t want dual-display, then remove all references in the xorg.conf to the second display (DFP-3). Use lspci in the VM to find the BusID of the NVidia GPU, and use that ID in the IsolateDevice/BusID options of the xorg.conf file. Replace the references to Z30iEDID.txt with the EDID file you capture and copy to the VM.

Example xorg.conf …

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "IsolateDevice" "PCI:0:8:0"
Option "Xinerama" "0"
EndSection

Section "Module"
# HP Remote Graphics Extension
Load "rge"
# extmod recommended for preventing XID overflow.
Load "extmod"
# Ensure X.org defaults are loaded
Load "glx"
Load "dbe"
Load "record"
EndSection

Section "InputDevice"
# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "HP Z30i"
HorizSync 24.0 - 98.0
VertRefresh 50.0 - 70.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "ModeValidation" "AllowNonEdidModes"
# BusID "PCI:0:8:0"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GRID K2"
EndSection

Section "Screen"
# Option "ModeDebug" "True"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "CustomEDID" "DFP-0:/etc/X11/Z30iEDID.txt; DFP-3:/etc/X11/Z30iEDID.txt"
Option "UseDisplayDevice" "DFP-0, DFP-3"
Option "ConnectedMonitor" "DFP-0, DFP-3"
Option "MetaModeOrientation" "DFP-0 LeftOf DFP-3"
# Option "IgnoreDisplayDevices" "CRT-0"
Option "Stereo" "0"
Option "metamodes" "DVI-D-0: nvidia-auto-select +0+0, DVI-D-1: nvidia-auto-select +2560+0; DVI-D-0: nvidia-auto-select +0+0"
Option "SLI" "Off"
Option "MultiGPU" "Off"
Option "BaseMosaic" "off"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
# Begin HP Remote Graphics Software
Option "Composite" "Disable"
# End HP Remote Graphics Software
EndSection
Z30iEDID.txt (768 Bytes)

OK, guess I can attach EDID after I create the reply. By the way, K1 may have different port assignments than K2 GPU … i.e. K2 GPU’s high link-rate ports were DFP-0 and DFP-3, but K1 GPU may have different ports for high link-rate. I do not know if the ports can vary between driver and/or vbios revisions.