I can't see any shader in Shader List when debugging GLSL

Environment: This is the first time I using Nsight. My GPU is GTX630M, and OS is win7 x64, version of OpenGL is 4.5. My program using FreeGlut and glew, it is like the first program in OpenGL Programming Guide Edition 8, Chapter 1.

I used two shaders, one is vertex shader(.vert), another is fragment shader(.frag).As the title, after I start graphics debugging, I CAN’T see ANY shader in Shader List, but the program can running in a little stumble.

How should I do so that I can see the shader? Thanks.

Hi HolyChen,

I’m not sure, but that looks like your are using laptop, since it’s mobile GPU. As you know, most laptop will have Optimuse system. I’m wondering whether your sample is running on NV’s GPU or just on Intel’s GPU?

If your sample is under Intel’s GPU, then you need to force disable Optimus system and make your sample run on NV’s GPU, then Nsight can work smoothly on your machine.