I have installed every ubuntu package downloaded by the SDK manager,but my jetpack 4.4 has not been upgraded to 4.5.1

from 4.4 to 4.5.1 is a new point or new minor point release ?

I’m doing : sudo nano /etc/apt/sources.list.d/nvidia-l4t-apt-source.list

deb https://repo.download.nvidia.com/jetson/common r32.5.1 main
deb https://repo.download.nvidia.com/jetson/t210 r32.5.1 main

You may try to first update to minor release r32.5, reboot and then just update to new release points.

However, if you have a custom board, be aware that these OTA updates are for devkits, so you may have to keep some versions of packages depending on what your custom board requires as kernel drivers and device tree.
Be aware that most kernel or bootloader updates would reset a default config in extlinux.conf, so you would have to check and edit it before rebooting.

E: The repository ‘https://repo.download.nvidia.com/jetson/common r32.5.1 Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ‘https://repo.download.nvidia.com/jetson/t210 r32.5.1 Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Try r32.5 instead of r32.5.1.

Setting up nvidia-l4t-bootloader (32.5.1-20210219084526) …
3448-300—1–jetson-nano-devkit-mmcblk0p1
Starting bootloader post-install procedure.

ERROR. Procedure for bootloader update FAILED.

Cannot install package. Exiting…
dpkg: error processing package nvidia-l4t-bootloader (–configure):
installed nvidia-l4t-bootloader package post-installation script subprocess returned error exit status 1
Setting up nvidia-l4t-xusb-firmware (32.5.1-20210219084526) …
3448-300—1–jetson-nano-devkit-mmcblk0p1
Starting xusb firmware post-install procedure.

ERROR. Procedure for xusb firmware update FAILED.

Cannot install package. Exiting…
dpkg: error processing package nvidia-l4t-xusb-firmware (–configure):
installed nvidia-l4t-xusb-firmware package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of nvidia-l4t-initrd:
nvidia-l4t-initrd depends on nvidia-l4t-xusb-firmware (= 32.5.1-20210219084526); however:
Package nvidia-l4t-xusb-firmware is not configured yet.

dpkg: error processing package nvidia-l4t-initrd (–configure):
dependency problems - leaving unconfigured

No apport report written because the error message indicates its a followup error from a previous failure.
Setting up nvidia-l4t-3d-core (32.5.1-20210505093645) …

dpkg: error processing package nvidia-l4t-initrd (–configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
nvidia-l4t-bootloader
nvidia-l4t-xusb-firmware
nvidia-l4t-initrd

I feel unsure for your case, so take my advice with caution…

Seems the problem is with xusb firmware and initrd.
What I would try in this case would be adding update-initramfs hook such as here (step 2).

Calling hook tegra-xusbfw
E: /usr/share/initramfs-tools/hooks/tegra-xusbfw failed with return 1.
update-initramfs: failed for /boot/initrd.img-4.15.0-1040-aws with 1.

No idea what this AWS initrd can be, nor what kernel on Jetson may be available for that.
Sorry I’m not able to help further.
Someone else may provide better help.

usb ports also work.

Seems weird… Again be aware that I’m just guessing… So better save any work in this Jetson before you have to reflash…

If out of idea, you may try this.

I fixed the problem. the solution is here :

at the end of the page :

monkeyy043y

Mar 8

Hi,

is your default python version 3.x?
If yes, change in the file /usr/sbin/l4t_payload_updater_t210, line 1:

#!/usr/bin/python
to
#!/usr/bin/python2

Milan

this is another little bug of nvidia. im realizing that the software of this board is full of little unresolved bugs. they are not criticals,but they are very annoying. but the worst thing that I hate is that nvidia does not care so much about the upgrading. the nano still runs with 18.04,but for this version of ubuntu is even ended the life cycle.

Not sure what you mean… for me /usr/bin/python and /usr/bin/python2 are just links to the same /usr/bin/python2.7.

I mean that the default version of python that I have is :

root@zi-desktop:/# python --version
Python 3.6.9

so,according with the suggestion of MIlan,I have changed python with python2 at the top of the file l4t_payload_updater_t210 and then I’ve reinstalled the nvidia-l4t-xusb-firmware package and the error is gone. Do u think that’s a bug or not ?

Seems clearer now ! Not sure which package or else installed python3 as default python, but it makes sense now. Thanks for sharing the explanation.

It looks like an issue when you switch to python3. Other users reported similar case recently.

Let me check this internally and see if we can update this in future release.

I’ve thought about this. what about to put a check on the top of this file :

/usr/sbin/l4t_payload_updater_t210

something like this :

if the default python version in use is 3x then use python2. if it is 2,then use python. easy :P

Is this an issue on host rather than on Jetson ? I have no such ‘l4t_payload_updater*’ in my NX.

The l4t_payload_updater_t210 is for T210 (TX1/Nano) only. NX should use something like “bl_payload_updater”.