Apt-upgrade on fresh JetsonNano install fails

I am struggling with the update of a fresh installation of Jetson Nano

  1. Downloaded and flashed the latest SD Card Image (sd-blob-b01.img)
  2. Rebooted and went through the setup process.
  3. Executed apt update and apt upgrade: a large number of packages were scheduled to be updated. Finally, I get this result:
probst@jetsonNano:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up nvidia-l4t-bootloader (32.7.3-20221122092935) ...
Starting bootloader post-install procedure.
ERROR. Procedure for bootloader update FAILED.
Cannot install package. Exiting...
dpkg: error processing package nvidia-l4t-bootloader (--configure):
 installed nvidia-l4t-bootloader package post-installation script subprocess returned error exit status 1
Setting up nvidia-l4t-xusb-firmware (32.7.3-20221122092935) ...
Starting xusb firmware post-install procedure.
ERROR. Procedure for xusb firmware update FAILED.
Cannot install package. Exiting...
dpkg: error processing package nvidia-l4t-xusb-firmware (--configure):
 installed nvidia-l4t-xusb-firmware package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of nvidia-l4t-initrd:
 nvidia-l4t-initrd depends on nvidia-l4t-xusb-firmware (= 32.7.3-20221122092935); however:
  Package nvidia-l4t-xusb-firmware is not configured yet.

dpkg: error processing package nvidia-l4t-initrd (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I understand from other posts that dist-upgrade is forbidden, but the regular update process should work, right?

Any help is appreciated.

Hi martin.probst

Are you using the devkit or custom board?

Do you follow the instructions from here?
NVIDIA Jetson Linux Developer Guide : Over-the-Air Update | NVIDIA Docs

Could you check the content in /etc/apt/sources.list.d/nvidia-l4t-apt-source.list?

Hi Kevin,

I am using a reComputer J1010 and thus probably not a devkit.

Yes, I followed the instructions for updating to a new point release.

You may refer to the following thread to check if it could help.
Errors on nvidia-l4t-xusb-firmware and nvidia-l4t-initrd

  1. modify your python version in /usr/sbin/l4t_payload_updater_t210
  2. direct re-flash Jetpack4.6.3 to your board through SDK Manager or flash script

1. Python Version
I already tried changing /usr/sbin/l4t_payload_updater_t210 and it didn’t work out. My Python version already points to version 2.7:

2. Jetpack 4.6.3
These options kind of exceed my abilities (I am new to the Jetson Nano environment). Re-flashing the SSD would be an easy option, though, since I ran the apt upgrade after a fresh installation anyway. The problem is, that I will run into the same issue again when I deliberately or accidentally execute apt upgrade. Do you see an option to avoid that upgrade-failure next time?


1 Like

Many thanks, this solution did the trick. Now I am just left with one kept back package, but that’s not a problem since the upgrade process does not fail anymore.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.