Switched from SD-Card to SSD > now package upgrade issues

Hi all,

Original issue >

I found slow or no response when attempting to run Emotions Project in the Getting Started with Jetson Nano Course - even though i had a SanDisk Extreme A2 128Gb SD Card).

What i did to solve original issue >
To increase storage I/O speed - I upgraded from SD Card to SSD and can now successfully boot from SSD, following the helpful blog post at > How to Boot Jetson Nano From USB 3.0 (Natively) with Jetpack 4.5.

I want to get back to learning, but unsure how to proceed due to new issue…

New issue >

Previously, with SD Card image i ran update/upgrade (NOT ‘dist’ or ‘full’ upgrade’) on occasional basis with no problems encountered… But now with booting from SSD image i get ‘dpkg’ upgrade errors specifically with the following packages -

  • nvidia-l4t-bootloader
  • nvidia-l4t-xusb-firmware
  • nvidia-l4t-initrd

(I have pasted the error output further below)

There may be an issue around ‘name’ of board as when i run >

sudo /usr/sbin/l4t_payload_updater_t210 --ver

it returns >

SPEC: 3448-400-0003-D.0-1-0-jetson-nano-devkit-sda1
Compatible SPEC: 3448-300-0003--1--jetson-nano-devkit-sda1

Error. Invalid board config name 3448-300-0003--1--jetson-nano-devkit-sda1

Original blog - Step 8 - (and I presume original Nvidia instructions) stated that a new mount name for the board had to be sda1 as follows >

sudo BOOTDEV=sda1 ./flash.sh --no-flash ${BOARD} sda1

How to proceed?

I’ve looked up similar posts about this dpkg error and some advice has been to sudo apt-mark hold.. such packages. like here >

Basically -
do i need the packages, should i mark hold them autoremove them etc? I have no classification libraries installed yet, but will need them soon to get back to the Emotions project. JetsonUtilities py script returns >

NVIDIA Jetson Nano (Developer Kit Version) L4T 32.5.1 [ JetPack UNKNOWN ] Ubuntu 18.04.5 LTS Kernel Version: 4.9.201-tegra CUDA NOT_INSTALLED CUDA Architecture: 5.3 OpenCV version: NOT_INSTALLED OpenCV Cuda: NO CUDNN: NOT_INSTALLED TensorRT: NOT_INSTALLED Vision Works: NOT_INSTALLED VPI: NOT_INSTALLED

All help appreciated,


Original error text >

Setting up nvidia-l4t-bootloader (32.5.1-20210219084526) ...
Starting bootloader post-install procedure.
ERROR. Procedure for bootloader update FAILED.
Cannot install package. Exiting...
dpkg: error processing package nvidia-l4t-bootloader (--configure):
 installed nvidia-l4t-bootloader package post-installation script subprocess returned error exit status 1
Setting up nvidia-l4t-xusb-firmware (32.5.1-20210219084526) ...
Starting xusb firmware post-install procedure.
ERROR. Procedure for xusb firmware update FAILED.
Cannot install package. Exiting...
dpkg: error processing package nvidia-l4t-xusb-firmware (--configure):
 installed nvidia-l4t-xusb-firmware package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of nvidia-l4t-initrd:
 nvidia-l4t-initrd depends on nvidia-l4t-xusb-firmware (= 32.5.1-20210219084526); however:
  Package nvidia-l4t-xusb-firmware is not configured yet.

dpkg: error processing package nvidia-l4t-initrd (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Actually, we do not support upgrade when you mount the device on to external storage or on a custom carrier board.

If you want to upgrade, you can directly flash with sdkmanager and then mount the drive again.