I try to install both of Tesla and geforce , but...

Hey guys,

I bought a new machine with two gpus, tesla c2075 and geforce lower model.
Because I have experienced “watchdog” in cuda programming when I used only one geforce previously, I have a plan that geforce is connected to a monitor without gpu computing and tesla is used for computing.

By the way, when I connect monitor with the geforce, the system does not recognize the geforce.
(Still, I didn’t install os, I will install fedora)
Only when the tesla is connected, the system boots correctly.

What can I do to resolve this problem ?

When I installed two geforces last year, I never experienced this phenomenon.

and… I have one more question.

The (tesla) provider suggested me “you don’t need to install another geforce when I install tesla c2075”

This suggestion is correct ?

As I mentioned, because I experienced the “watchdog” with long cuda program, I bought another geforce.

Linux or windows? On linux you have to modify the xorg.conf, because by default is suing the device which is on pci 1 slot.

I’ll treat your questions separately. First, it would be helpful if you listed your specific hardware – what model GeForce card? What MFR and model of motherboard? UEFI or non-UEFI setup? (e.g. Legacy BIOS/CSM boot?) Have you updated the motherboard BIOS to the latest version? – I recommend you do this last step first in case a new BIOS resolves the issue.

I ran into a similar issue last weekend when I was substituting a Quadro K6000 for a GTX Titan on my MSI X79A-GD45 (8D) motherboard with the latest 12.4 BIOS version. When I connected the video output to a GK208-based Zotac GeForce GT630 and powered on the system (same one I had when I had the GTX Titan installed), the BIOS froze on POST. I had to connect the video output to the Quadro K6000, and that way I was able to boot into Windows 8.1, where I was able to use nvidia-smi to enable TCC mode on the Quadro K6000 via:

After this, I shut down the computer, moved the video output to the GT630, and only then after TCC mode was enabled on the K6000, I was able to get the computer to POST past the BIOS freeze. It seems like the Quadro K6000 UEFI BIOS (I boot in UEFI) is very aggresive in taking control of the video output, or because it’s so alike to the GT630 that has a similar UEFI BIOS, or some variation of that… or maybe it’s just my motherboard’s BIOS that doesn’t negotiate the particular situation correctly, or a combination of those things. I even tried switching slots between the cards and it behaved in the same way – a freeze if GeForce card was connected to video output, no freeze if video output was connected to K6000.

So in short, enable TCC mode (change from WDDM mode to TCC mode) via nvidia-smi on a Windows installation (you cannot change these modes in Linux) and see if it boots with the display output connected to the GeForce card. That’s what worked for me.

It is possible that this entire freeze issue could have been avoided by booting the system in Legacy BIOS/CSM mode, but since I already had a working Windows 8.l install, I did not want to do this, as it would mean a few more hours in lost time of re-installing software/reconfiguration/etc. For your case, however, if you have the option of doing a Legacy BIOS boot vs UEFI, try that and see if it makes a difference without having to force TCC mode on the card from a Windows installation with NVIDIA drivers.

As for your second question. You do not NEED a separate card with a Tesla, but if you have demanding CUDA jobs being sent to the Tesla card with a video output connected, you could see your display hang and/or not refresh constantly, in addition to the watchdog issue and the fact that you would not be able to enable TCC mode in Windows which gets rid of some overhead. Of course, if you use Linux, there is no such thing as TCC in Linux, so it doesn’t matter, but it does in Windows.

This board’s quirky editor fails to edit my post, so I’ll add my update here:

Edit: I was able to switch back successfully to WDDM mode on the K6000 with no freezing upon a restart, so perhaps the issues I was experiencing are just related to a BIOS NVRAM/settings hiccup.