Win7 x64 with 2x C2050 Install problems

I’ve got a Supermicro mainboard with onboard Matrox G200 video, and I’m trying to install 2 Tesla C2050 cards strictly as GPUs. I’m running Windows 7 x64 Pro. I can’t get CUDA to recognize the cards, no matter what drivers I use (release or beta). Any suggestions for getting this configuration to work?

–Penn

If your board is like any of the other Supermicro and Tyan boards I have used, you might need to disable the G200 in the BIOS before the VGA bios of the C2050s will be loaded at boot and enumerated on the PCI bus where the OS can find them.

If your board is like any of the other Supermicro and Tyan boards I have used, you might need to disable the G200 in the BIOS before the VGA bios of the C2050s will be loaded at boot and enumerated on the PCI bus where the OS can find them.

Does that mean that I’d then be using the Teslas as primary video cards?

–Penn

Does that mean that I’d then be using the Teslas as primary video cards?

–Penn

Unfortunately, yes (if I am correct, that is). If you have a free PCI-e or PCI slot, it might be work getting a small Quadro NVS or consumer Geforce card to drive the display and leave the C2050s free.

Unfortunately, yes (if I am correct, that is). If you have a free PCI-e or PCI slot, it might be work getting a small Quadro NVS or consumer Geforce card to drive the display and leave the C2050s free.

so you can actually do this in the R260/CUDA 3.2 driver, but it takes some registry editing to enable TCC on the two C2050s. (if you had M2050s, this would have just worked!)

  1. in regedit, go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E968-E325-11CE-BFC1-08002BE10318}
  2. look through the list of device nodes (labeled 0000, 0001, etc.)
  3. if HardwareInformation.AdapterString says “Tesla C2050”, add a DWORD called AdapterType and set it to 2.
  4. do that for both devices.
  5. reboot.

this is the way to force TCC on when you can’t load the WDDM driver due to a standard VGA driver being present. note that this will only force it on for Tesla cards, it won’t work on GeForce or Quadro. also, this will disable all display functionality on the Tesla cards, so don’t try to boot with those as a display card.

so you can actually do this in the R260/CUDA 3.2 driver, but it takes some registry editing to enable TCC on the two C2050s. (if you had M2050s, this would have just worked!)

  1. in regedit, go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E968-E325-11CE-BFC1-08002BE10318}
  2. look through the list of device nodes (labeled 0000, 0001, etc.)
  3. if HardwareInformation.AdapterString says “Tesla C2050”, add a DWORD called AdapterType and set it to 2.
  4. do that for both devices.
  5. reboot.

this is the way to force TCC on when you can’t load the WDDM driver due to a standard VGA driver being present. note that this will only force it on for Tesla cards, it won’t work on GeForce or Quadro. also, this will disable all display functionality on the Tesla cards, so don’t try to boot with those as a display card.

I went in with Regedit, and found the two devicenodes that rpresented the two Tesla cards (0000 and 0002 in this case).

There was no HardwareInformation.AdapterString key.

I added the DWORD and set it to 2 as instructed (for only one card, just to be safe), and then rebooted and attempted to run a Devicequery from CUDA, and got the same error as before.

Is there a specific driver version that I should be trying this with (260 versus 259, for example)? Should I be reinstalling the device drivers after setting the registry?

–Penn

I went in with Regedit, and found the two devicenodes that rpresented the two Tesla cards (0000 and 0002 in this case).

There was no HardwareInformation.AdapterString key.

I added the DWORD and set it to 2 as instructed (for only one card, just to be safe), and then rebooted and attempted to run a Devicequery from CUDA, and got the same error as before.

Is there a specific driver version that I should be trying this with (260 versus 259, for example)? Should I be reinstalling the device drivers after setting the registry?

–Penn

what I posted will only work with 260.61 (available from www.nvidia.com/getcuda ).

what I posted will only work with 260.61 (available from www.nvidia.com/getcuda ).

That appears to do the trick. I was on the 259 drivers (having gone back and forth several times).

Thanks very much, you have been most helpful.

–Penn

That appears to do the trick. I was on the 259 drivers (having gone back and forth several times).

Thanks very much, you have been most helpful.

–Penn

I’m no sure if this is the right forum, but I think that we have a similar problem. We have the following hardware configuration:

1 6016GT-TF-FM205 Supermicro GPU 56/5500 QPI to 6.4 GT/s

2 GPU-NVC2050 (FERMI) Nvidia Fermi C2050 GPU Card

2 INTEL WESTMERE E5620 Westmere 4C E5620 2.4GHz 12M 80W

12 DR340L-HL02-ER13 4GB DDR3-1333 ECC REG Dual Rank

1 ST31000528AS Seagate Barracuda 1Tb 32Mb 7200.12 SATA

We have configured this with dual boot, Windows 2008 R2 64 bits and Linux Fedora, and we use it via Remote Desktop (on Win). The Linux configuration seems ok, but, under Windows, the two Tesla cards are not properly recognized.

I have installed and reinstalled the Nvidia recommended driver, 260.83-tesla-winserv2008r2-64bit-english-whql, and also tried with the default VGA driver and the Supermicro recommended driver, Matrox G200e Graphics v1.02.05s.

Under device manager, I can see three devices, the Matrox and the two Teslas (in this order), the drivers seem to be working “properly”, but all CUDA attempts fail.

For example:

deviceQueryDrv.exe

CUDA Device Query (Driver API) statically linked version

Cuda driver error 3 in file ‘.\deviceQueryDrv.cpp’ in line 42.

deviceQuery.exe

deviceQuery.exe Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount FAILED CUDA Driver and Runtime version may be mismatched.

FAILED

oclDeviceQuery.exe

oclDeviceQuery.e

xe Starting…

OpenCL SW Info:

Error -1001 in clGetPlatformIDs Call !!!

!!! Error # -1000 (Unspecified Error) at line 38 , in file .\oclDeviceQuery.cpp !!!

Exiting…

I attach the GPU-Z report.

Could you please advise?

Thanks very much

Radu

I’m no sure if this is the right forum, but I think that we have a similar problem. We have the following hardware configuration:

1 6016GT-TF-FM205 Supermicro GPU 56/5500 QPI to 6.4 GT/s

2 GPU-NVC2050 (FERMI) Nvidia Fermi C2050 GPU Card

2 INTEL WESTMERE E5620 Westmere 4C E5620 2.4GHz 12M 80W

12 DR340L-HL02-ER13 4GB DDR3-1333 ECC REG Dual Rank

1 ST31000528AS Seagate Barracuda 1Tb 32Mb 7200.12 SATA

We have configured this with dual boot, Windows 2008 R2 64 bits and Linux Fedora, and we use it via Remote Desktop (on Win). The Linux configuration seems ok, but, under Windows, the two Tesla cards are not properly recognized.

I have installed and reinstalled the Nvidia recommended driver, 260.83-tesla-winserv2008r2-64bit-english-whql, and also tried with the default VGA driver and the Supermicro recommended driver, Matrox G200e Graphics v1.02.05s.

Under device manager, I can see three devices, the Matrox and the two Teslas (in this order), the drivers seem to be working “properly”, but all CUDA attempts fail.

For example:

deviceQueryDrv.exe

CUDA Device Query (Driver API) statically linked version

Cuda driver error 3 in file ‘.\deviceQueryDrv.cpp’ in line 42.

deviceQuery.exe

deviceQuery.exe Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount FAILED CUDA Driver and Runtime version may be mismatched.

FAILED

oclDeviceQuery.exe

oclDeviceQuery.e

xe Starting…

OpenCL SW Info:

Error -1001 in clGetPlatformIDs Call !!!

!!! Error # -1000 (Unspecified Error) at line 38 , in file .\oclDeviceQuery.cpp !!!

Exiting…

I attach the GPU-Z report.

Could you please advise?

Thanks very much

Radu