I was unable to compile and install MXNET on the jetson nano,Is there an official installation tutorial?

Hi,

For build MXNet from source with TensorRT support, please check this comment:

Thanks.

1 Like

Thank you for the pre-made script, it’s very helpful! I’ve gotten this to work with some tweaks on a fresh Jetpack 4.4 install on the TX2. I can’t quite get it to work on the Nano (fresh sd card image) however… I’ve tried adding up to 12gb swap, set swappiness to 90% but it always runs out of memory on the very last step ‘Building TensorRT Engine’ OOMKiller always kills this before it can complete.

  1. install sudo apt-get install python3-pip libprotoc-dev protobuf-compiler
  2. export export CUDACXX="/usr/local/cuda/bin/nvcc" or set in /etc/environment and reboot
  3. install apt-get install python-setuptools

FWIW, I used this script but had to add export LD_LIBRARY_PATH=/usr/local/lib/python3.6/dist-packages/mxnet:$LD_LIBRARY_PATH to the end of ~/.profile to be able to import mxnet. I have a TX2 with a fresh install of Jetpack 4.4. I hope this info helps someone.

1 Like

Hi there!
I just got a Jetson Nano (flashed using the jetson-nano-jp451-sd-card-image file), and installed MXNet 1.7.0 by using the ‘autoinstall_mxnet.sh’ script.
I was getting the error "Illegal instruction (core dumped)” when importing MXNet, but I fixed it by adding

export OPENBLAS_CORETYPE=ARMV8

to my .bashrc file, as mentioned in this discussion.
However, when running pip list, I can see the mxnet 1.7.0 entry…shouldn’t it be mxnet-cu102, or something similar?

Then, I needed to install GluonCV. I cloned the repo and tried the installation script:

git clone https://github.com/dmlc/gluon-cv
cd gluon-cv && python setup.py install --user

I got some dependencies error when it comes to the matplotlib installation:

Searching for matplotlib
Reading https://pypi.org/simple/matplotlib/
Downloading 
Best match: matplotlib 3.4.2
Processing matplotlib-3.4.2.tar.gz
Writing /tmp/easy_install-g5zib6k8/matplotlib-3.4.2/setup.cfg
Running matplotlib-3.4.2/setup.py -q bdist_egg --dist-dir /tmp/easy_install-g5zib6k8/matplotlib-3.4.2/egg-dist-tmp-g0hdz3xh
error: Setup script exited with 
Beginning with Matplotlib 3.4, Python 3.7 or above is required.
You are using Python 3.6.9.

but gluoncv seemed to be installed normally, and I installed matplotlib later.
The problem is that now I’m trying to run some example object detection code, and I’m getting the error:

MXNet Error: Build with USE_OPENCV=1 for image io

Didn’t the autoinstall_mxnet.sh enable that? Can I fix it, or should I flash the card back and reinstall everything following the manual procedure in post #8?

Hi lews_therin,

Please help to open a new topic. Thanks