" Illegal instruction (core dumped)" Xavier

when i import numpy on python3 shell, it says " Illegal instruction (core dumped)" on xavier.How can i solve this problem?

my pip3 list is :

Cython 0.29.21
numpy 1.19.5
pip 20.3.3
setuptools 51.0.0
torch 1.1.0
wheel 0.36.1

3 Likes

Hi,

It seems like you are facing a similar issue as the below topic:

Could you try the suggestion to see if it also works for you first?
Thanks.

5 Likes

when i open python on shell like this :

OPENBLAS_CORETYPE=ARMV8 python3

it solved my problem thanks

5 Likes

This works for me. However is there a way to make it work without having to constantly type the whole command, and just type python3 instead ? I’m still a newbie into all this and would appreciate any positive feedback. Thanks.

2 Likes

Hi @mpico602, two ways:

  1. Run export OPENBLAS_CORETYPE=ARMV8 in your terminal. It will remain active as long as that terminal remains open.

  2. Add export OPENBLAS_CORETYPE=ARMV8 to your ~/.bashrc. It will set that environment variable on every new terminal that is opened.

2 Likes

Thanks @dusty_nv I tried the second approach and It is now working perfectly.

2 Likes

I pinned the numpy version to something smaller than 1.19.5 as mentioned in the numpy issue thread:

numpy<=1.19.4

and don’t have to set OPENBLAS_CORETYPE=ARMV8 anymore.