Imx390-gw5200-gmsl2 is not work on jetpack4.4

Hi all,

I have two LI-IMX390-GW5200-GMSL2 and connect to MAX9295 and Max9296 on TX2 and own board.
build Jetpack 4.4 source and testing that but it is not work.

i guess jetpack’s imx390 drivers is not support imx390-gw5200 and
i cant find any gw5200 document or sample.

so i tried to changing device tree like this for testing.

// tegra186-camera-imx390-a00.dtsi
mode0 {/mode IMX390_MODE_1920X1080_CROP_30FPS/
mclk_khz = “24000”;
num_lanes = “2”;

dynamic_pixel_bit_depth = "16";
csi_pixel_bit_depth = "16";
mode_type = "yuv";
pixel_phase = "yuyv";

// …
error solved but cam still not work.

is any other idea?

my camera model is

I would suggest to get the driver from Leopard for it.

they said that imx390 + gw5200 is different .
but they dont have device driver .

I guess this device is for the driver system instead of L4T.

Hi nkw3000,
We have Xavier IMX390-GW5200-GMSl2 driver but no TX2 driver guide yet.

i forget report a result. I think that GW5200 is setting all so dont need a setting register on max9295 + gw5200 camera without reset.