Initial flash failed on new TX2 module

Hello,

We are flashing new TX2 modules with a massflash blob.
nvmflash does flash correctly all partitions.

But we have one module that fails with the following error.
As if some partition was not correctly flashed:

*** Boot Rom communication

/cam5/mfi_jetson-tx2/tegrarcm_v2 --instance 3-2 --chip 0x18 0 --rcm rcm_list_signed.xml

BR_CID: 0x8180100164122242040000000b020380

RCM version 0X180001

Boot Rom communication completed

*** Boot Rom communication succeeded.

 

*** Checking applet

/cam5/mfi_jetson-tx2/tegrarcm_v2 --instance 3-2 --isapplet

Applet version 01.00.0000

*** Checking applet succeeded.

 

*** Sending BCTs

/cam5/mfi_jetson-tx2/tegrarcm_v2 --instance 3-2 --download bct_bootrom br_bct_BR.bct --download bct_mb1 mb1_bct_MB1_sigheader.bct.encrypt

Applet version 01.00.0000

Sending bct_bootrom

[................................................] 100%

Sending bct_mb1

[................................................] 100%

*** Sending BCTs succeeded.

 

*** Sending bootloader and pre-requisite binaries

/cam5/mfi_jetson-tx2/tegrarcm_v2 --instance 3-2 --download blob blob.bin

Applet version 01.00.0000

Sending blob

[................................................] 100%

*** Sending bootloader and pre-requisite binaries succeeded.

 

*** Booting Recovery

/cam5/mfi_jetson-tx2/tegrarcm_v2 --instance 3-2 --boot recovery

Applet version 01.00.0000

*** Booting Recovery succeeded.

 

*** Checking applet

/cam5/mfi_jetson-tx2/tegrarcm_v2 --instance 3-2 --isapplet

 

*** Checking CPU bootloader

/cam5/mfi_jetson-tx2/tegradevflash_v2 --instance 3-2 --iscpubl

CPU Bootloader is not running on device.

*** Error: Checking CPU bootloader failed.

Here’s the serial line output:

[0042.173] E> Waypoint-0.5 ACK pending: 0x8

[0042.177] C> MTS error (2) : dram alias check failure

[0042.182] C> cpu waypoint 0.5 failed

[0042.185] C> ERROR: Highest Layer Module = 0x32, Lowest Layer Module = 0x32,

Aux Info = 0x1, Reason = 0x6

[0016.266] E> Waypoint-0.5 ACK pending: 0x8

[0016.270] C> MTS error (2) : dram alias check failure

[0016.275] C> cpu waypoint 0.5 failed

[0016.278] C> ERROR: Highest Layer Module = 0x32, Lowest Layer Module = 0x32,

Aux Info = 0x1, Reason = 0x6

Thank you for your help.

Tanguy

How many modules been flashed successfully?
Only one moduel got this problme, all the rest are OK?
If yes, suggest to do the RMA or contact with distributor to do the swap.

Yes all other did succeed.
We will do the RMA for this one.

Thanks for your feedback

Hi @kayccc ,

We now have two models more that fail with same error.
We tested the module on a devkit and put it in recovery mode, nothing shows on serial line when flashing.

Kind regards,

Tanguy

Failure rate?
Please contact with distributor to do the swap.

Thanks

Hi @TANGUY.MEZZANO

May I know which JetPack/L4T SW veraion your flashed?
We need to exclude that’s related with the PCN 206440 .

Hi @kayccc

We are using L4T 32.3.1 and L4T 32.6.1.
The problem was PCN 206440, we were not aware of it.
And there was sadly no L4T 32.3.2 with that correction.

Problem solved, thank you.