Install a specific cuda version for ubuntu 16.04


I have troubles to understand and install the installation process for a specific cuda version that is needed as a dependency for a program that I want to run.

The program demands cuda 8.0 GA 1 (cuda 8.0.44). I try to install it on a ubuntu 16.04.

What I tried so far:

  1. Cleanup
sudo apt-get update
sudo apt-get upgrade
sudo apt autoremove -y
  1. Get the specific .deb file for my system and cuda version and install it with the package manager:
sudo dpkg -i cuda-repo-ubuntu1604_8.0.44-1_amd64.deb
  1. Now here is where I struggle. On the official download page it tells me to run:
`sudo apt-get update`
`sudo apt-get install cuda`

But that installs cuda 9.1.
When I run

sudo apt-get update
sudo apt-get install -y cuda-8-0

it installs cuda 8.0.61 which is the GA 2 version. But the version I need is cuda 8.0.44.
When I run

sudo apt-get install -y cuda-8-0=8.0.44-1

it still installs cuda 8.0.61.

How can I install the cuda version from the .deb package instead of any other one?

Update: I got it to run. My mistake was, that I didn’t remove all the existing nvidia and cuda files before the installation:

sudo apt-get --purge -y remove 'cuda*'
sudo apt-get --purge -y remove 'nvidia*'
sudo reboot

after that, I just downloaded the local .deb package, added it via dpkg -i and the run apt-get update and apt-get install cuda.