Install tensorrt on a Docker Container (Jetson AGX Xavier, 35.4.1, Jetpack 5.1.2)

I am trying to install tensorrt on a docker container but struggling to. When I check for it locally outside of a container, I can find it and confirm my version as 8.5.2.2.

How can I install it on the docker container using a Docker File?

I tried doing python3 install tenssort but was running into errors

Hi,

Which container do you use?
On Jetson, please use a l4t-based container for compatibility.

Within the container, it should be:

$ apt install nvidia-tensorrt

Thanks.

I was using l47-base-35.4.1

WHen I tried using apt install nvidia-tensorrt, I was running into issues saying I should use pip install.

I added a second FROM statement in my Dockerfile and used the tag “nvcr.io/nvidia/l4t-tensorrt:r8.5.2-runtime” to get tenssort. Is this tenssorrt nvidia-tensorrt?

Hi

Yes, you can use the image directly
Thanks.

However when I try to look for the tensorrt package in my container it does not seem to be installed.

Hi,

Let’s track the following issue on the newly opened topic:

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.