Running TensorRT 7 in nvidia docker on Jetson TX2

I am attempting to run a library that depends on TensorRT 7 (GitHub - wang-xinyu/tensorrtx: Implementation of popular deep learning networks with TensorRT network definition API) on my jetson. I have set up a dockerfile as the l4t-base package demonstrates. However I am unsure how to change the default version of tensorrt from to any of the 7.x versions. I have tried installing like here:

and also adding the keyring from here before doing that:

And also tried from pip

Steps to replicate:
Use Jetpack 4.6.3 on Jetson Tx2
l4t-base image(I use r35.2.1): NVIDIA L4T Base | NVIDIA NGC
Run this sample Dockerfile provided by Nvidia in nvidia-docker(I made sure to bump docker tag as provided in makefile): nvidia / container-images / l4t-jetpack ยท GitLab
[Attempt to install TensorRT as above?]

(base) root@9a6a65392ec2:/tensorrt_test# python3 -m pip install --upgrade tensorrt
ERROR: Could not find a version that satisfies the requirement tensorrt (from versions: 0.0.1.dev5, 0.0.1)
ERROR: No matching distribution found for tensorrt

After installing keyring:

(base) root@9a6a65392ec2:/tensorrt_test# apt-cache madison nvidia-tensorrt-dev
nvidia-tensorrt-dev |   5.1-b147 | r35.2/main arm64 Packages
(base) root@9a6a65392ec2:/tensorrt_test# apt-cache madison tensorrt-dev
tensorrt-dev | | r35.2/main arm64 Packages
(base) root@9a6a65392ec2:/tensorrt_test# 

Fundamentally my question is: where can I get a version of TensorRT7 that runs on Jetson Tx2(aarch64), without going through jetpack (since Iโ€™m using a container)


On JetPack 4, the l4t-based container will mount the library from Jetson instead of installing it.
Since TensorRT 7 has dependencies on r32.5, you will need to reflash the device with JetPack 4.5.


1 Like

Will do, thanks for clearing this up ๐Ÿ‘

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.