TensorRT Version on Nvidia Jetson TX2

Hello,

I am using Nvidia Jetson TX2 with the jetpack 4.2.1. I need this jetpack for compatibility with a specific camera.
However, this jetpack installed the version 5.1.6.1 of TensorRT.
My team worked previously on an AI, but with the version 7.1.3.4 of TensorRT. Because of this, the classes used in our program can’t be found in the file NvInfer.h, which makes it impossible for me to use the AI with my camera.

Is there a way to only change the TensorRT version? (I tried with debian or tar files, but it does not work since the Jetson TX2 has an aarch64 architecture) .
If not, is it possible at least to change the NvInfer.h file and replace it by the one which can be found in the version 7.1.3.4?

Regards,
Tim

Hi,

Unfortunately, TensorRT has some dependencies between the GPU driver(OS) and the CUDA version.
So you will need to upgrade the JetPack version as well.

Since v4.2.1 is quite old, is it possible to ask the camera vendor to see if the newer JetPack is supported?

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.