[Installation] app failed to start because cudart.dll was not found.


A search of the forum for “cudart” yielded no results so I hope this isn’t asked every 5 minutes…

I am having trouble running many of the examples from the NVIDIA GPU Computing SDK.

For example, when running oceanFFT.exe, I get a message box:

“The application has failed to start because cudart.dll was not found. Re-installing the application may fix this problem.”

This occurs when I run the examples through the SDK browser, or simply by double-clicking on the executables in an explorer window.

System information:
Windows XP Home (32 bit) + SP3
Geforce 9800 GTX, Driver version 191.07

The CUDA toolkit 2.3 (cudatoolkit_2.3_win_32.exe) was installed under:
In case it is relevant, M: is really a mapping to C:\Documents and Settings\Dev that is set up with the ‘subst’ console command when I login.
This was installed with regular user privileges (Dev is not an admin account)

The CUDA SDK 2.3 (cudasdk_2.3_win_32.exe) was installed under:
C:\Documents and Settings\Dev\libs\NVIDIA GPU Computing SDK
I had to right click and “Run as” an administrator to install this, as for some reason the installer barfed when run with regular user privileges. When it asked me whether I wanted to install it for “All Users” or the “Current User”, I selected “Current User”. Though whether it thought the current user was the administrator account under which I was running the installer, or the user under which I logged in (Dev), I don’t know…

Some system-wide environment variables were created:
NVSDKCOMPUTE_ROOT = C:\Documents and Settings\Dev\libs\NVIDIA GPU Computing SDK
NVSDKCUDA_ROOT = C:\Documents and Settings\Dev\libs\NVIDIA GPU Computing SDK\C

I tried rebooting after installation, but still no luck.

If I copy the DLLs from M:\libs\CUDA\bin to %NVSDKCUDA_ROOT%\bin\win32\Release, I am then able to run the example programs fine. But I assume I shouldn’t have to do this and there’s a problem with my installation. I guess there should be something in my environment that points to the DLLs?

Any help is very much appreciated.



you must add “M:\libs\CUDA\bin” to environment variable “path”, check it.

That did the trick. Thank you very much.

Should this not be the responsibility of the installer, though (In other words, should I file a bug somewhere)?