Installation of Tensorflow on Jetson Nano

I have a Jetson Nano with tensorflow 2.2.0 on it.

On my PC I have build a docker image using the tf2 Dockerfile of object_detection. This states FROM tensorflow/tensorflow:gpu-2.2.0.

I then trained the network which took some time.

What I failed to spot is that the Docker build actually contains tensorflow 2.3 (The docker build process at the very end upgrades tensorflow 2.2.0 to 2.3.0).

So now I have a trained tf 2.3.0 model that can not be run on the Jetson Nano running tf 2.2.0.

I have tried upgrading the Nano to 2.3.0 but that fails because it requires tensorflow addons 2.3 which cannot be installed using pip. It has to be built from the source which requires an unknown version of bazel which in turn has to eb built from the source. This route potentially ends in a broken Nano because it may require an Nvidia specific distribution of tensorflow which is not released yet.

I have tried to keep Docker from upgrading to 2.3.0 but I can’t make that work either.

When will tensorflow 2.3 be released for Jetson Nano?

1 Like

What is your version python ?

Hi Mohammed,

I have made some progress. I managed to compile and install Bazel and Tensorflow 2.3 on my Jetson Nano (50+ hours compilation time). But then I found out there was still a problem loading the saved model.
Apparently you have to supply tensorflow.saved_model.load() with the file name without extension. If you don’t then you get a misleading error message about tensor shape mismatches.

So now I can load my model using tensorflow 2.3.0, python 3.6.9 on the Jetson Nano. Problem solved.