Installer failed CUDA 8 on Win 10, K3100M

The NVIDIA Installer for CUDA 8.0 is always failing when trying to install the Graphics Driver 376.51. This is a new installation.

I’ve installed Visual Studio Community 2015 and 2017, shutdown McAfee firewall and virusscan, and launched the installer as Administrator. I have a Dell Precision M6800 laptop with a Quadro K3100M.

My goal is to get tensorflow-gpu up and running.

Is there an error log somewhere, or something else I can do?

Thanks,

  1. Remove any existing graphics drivers using DDU:
    http://www.wagnardsoft.com/content/display-driver-uninstaller-ddu-v17063-released
    Don’t forget to reboot the system afterwards

  2. Install latest drivers as per this page:
    http://www.nvidia.com/Download/index.aspx?lang=en-us

  3. Install latest CUDA toolkit without the NVIDIA display driver (there might be an advanced/customize step in the install wizard, I forget the name)
    https://developer.nvidia.com/cuda-toolkit

I’m very frustrated. This system sucks. I can see the toolkit is installed. See below. But all components are not installed. There is integration with Visual Studio. I had to step back from the latest Toolkit-okay if everything works. There is no Nsight installed. Can’t use Visual Studio. Can’t find cl.exe from command line. There are very many references on the internet but no real solutions. NVIDIA’s online helpers don’t seem to know how to fix it. I was able to change Quadro K620 from WDDM to TCC mode. Is there a clear correct way to make things work?

NVIDIA System Information report created on: 04/18/2017 01:29:40
System name: RHPT-PC

[Display]
Operating System: Windows 10 Pro, 64-bit
DirectX version: 12.0
GPU processor: Quadro 4000
Driver version: 377.11
Direct3D API version: 11.2
Direct3D feature level: 11_0
CUDA Cores: 256
Core clock: 475 MHz
Shader clock: 950 MHz
Memory data rate: 2808 MHz
Memory interface: 256-bit
Memory bandwidth: 89.86 GB/s
Total available graphics memory: 14334 MB
Dedicated video memory: 2048 MB GDDR5
System video memory: 0 MB
Shared system memory: 12286 MB
Video BIOS version: 70.00.37.00.03
IRQ: Not used
Bus: PCI Express x16 Gen2
Device Id: 10DE 06DD 078010DE
Part Number: 1031 0500
GPU processor: Quadro K620
Driver version: 377.11
CUDA Cores: 384
Core clock: 1058 MHz
Memory data rate: 1800 MHz
Memory interface: 128-bit
Memory bandwidth: 28.80 GB/s
Memory: 0 MB
Memory type: DDR3
Total available graphics memory: 2048 MB
Dedicated video memory: 2048 MB DDR3
Video BIOS version: 82.07.7A.00.12
IRQ: Not used
Bus: PCI Express x16 Gen2
Device Id: 10DE 13BB 109810DE
Part Number: 2012 0504

[Components]

nvui.dll 8.17.13.7711 NVIDIA User Experience Driver Component
nvxdsync.exe 8.17.13.7711 NVIDIA User Experience Driver Component
nvxdplcy.dll 8.17.13.7711 NVIDIA User Experience Driver Component
nvxdbat.dll 8.17.13.7711 NVIDIA User Experience Driver Component
nvxdapix.dll 8.17.13.7711 NVIDIA User Experience Driver Component
NVCPL.DLL 8.17.13.7711 NVIDIA User Experience Driver Component
nvCplUIR.dll 8.1.1050.0 NVIDIA Control Panel
nvCplUI.exe 8.1.1050.0 NVIDIA Control Panel
nvWSSR.dll 6.14.13.7711 NVIDIA Workstation Server
nvWSS.dll 6.14.13.7711 NVIDIA Workstation Server
nvViTvSR.dll 6.14.13.7711 NVIDIA Video Server
nvViTvS.dll 6.14.13.7711 NVIDIA Video Server
nvDispSR.dll 6.14.13.7711 NVIDIA Display Server
NVMCTRAY.DLL 8.17.13.7711 NVIDIA Media Center Library
nvDispS.dll 6.14.13.7711 NVIDIA Display Server
NVCUDA.DLL 6.14.13.7711 NVIDIA CUDA 8.0.0 driver
nvGameSR.dll 6.14.13.7711 NVIDIA 3D Settings Server
nvGameS.dll 6.14.13.7711 NVIDIA 3D Settings Server

follow the instructions in the windows install guide

http://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html#abstract

For either K620 or Q4000 (your output also shows a Q4000) you should be able to use the 8.0.61 CUDA installer as-is. The bundled driver should work for either of those GPUs.

Please be sure to follow the guide carefully, starting with system requirements. Do you have a supported version of Visual Studio?

After you have installed CUDA, be sure to run the verification steps, to be sure that the CUDA install is correct, before trying other things (like how to do anything from the command line - which is not covered there, and is really a separate issue – NVIDIA makes no claims about anything working correctly “from the command line”. The clearly supported path is to use the VS IDE, projects, etc.)

My two cents:

I had a ton of problems trying to get my CUDA 8.0 installed properly. I had a previous version installed and I wanted to upgrade so I uninstalled it and tried to install CUDA 8.0 (for tensorflow 1.3). The installation failed every single time, I tried to downgrade to CUDA 7.5 and was able to install it but had a ton of problems with tensorflow (I will describe those in another forum). Long story short: what worked for me was:

  1. Uninstall EVERY NVIDIA component (except the display graphics driver)

  2. Download CUDA toolkit 8.0 (and the patch)

  3. Check the CheckSum MD5 (I used MS https://www.microsoft.com/en-ca/download/confirmation.aspx?id=11533 but any would do) to make sure they were OK (it happened several times that the installer was not dowloaded properly because my WiFi router apparently).

  4. Run the CUDA toolkit installer as root

  5. download the cudnn 8.0 v6 and add its location to the PATH variable

Hope that helps and saves some headaches…