Installing 2.3 CUDA on a 2.26 Octocore MacPro 2009 w/GTX285 issues...

https://www.evga.com/forums/tm.asp?m=100724…page=5&key=

as seen in this thread about simply getting a teapot app running in the back, I have been having issues with properly getting the CUDA 2.3 to work, I have double and triple checked that I have installed the drivers/toolkit and SDK’s and following the PDF Step by Step. Once I get to this step I hit a snag.

Compiling the Examples
The version of the CUDA Toolkit can be checked by running nvcc –V in a terminal
window. nvcc is the command to run the compiler driver that compiles CUDA
programs. It calls the gcc compiler for C code and the NVIDIA PTX compiler for
the CUDA code.
NVIDIA includes sample programs in source form in the CUDA SDK. You should
compile them all by changing to /Developer/GPU Computing/C and typing make.
The resulting binaries will be installed in the directory /Developer/GPU
Computing/C/bin/darwin/release. If the compilation fails because find gcc, the compiler should be installed via an Xcode installation.

When I am asked to change to /developer/GPU Computing i get this error.

/developer/GPU: No such file or directory. Even though I can open up my hard drive and find the directory myself but it doesn’t want to let me do the “make” function in the directory. Almost as though the terminal freaks out thinking a space shouldn’t be there so it doesn’t detect the word “computing” past the space between it and GPU.

I have even tried installing the SDK’s to a different name by changing the folder it goes to when installing to something with one word for a name and it works up past the “make” function, but the moment I try to do a devicequery or postProcessGL it doesn’t work, says the command doesn’t exist, probably because the program is expecting the files in the default GPU Computing I am guessing. Little help would be appreciated.

cd /Developer/GPU\ Computing/ is what you want

ok next step i did cd /developer/GPU\ Computing/c/bin/darwin/release, and when I tried to do devicequery it says command not found…

./deviceQuery

(welcome to unix :) )

Hurrah! Spinning Teapot! Good to go thanks a bunch :D