Installing cuda 5 using gcc version 4.5 on Linux Mint 14 based on gcc 4.7 (unsupported)?

Hello,

I’d like to install cuda 5 on my new Notebook. The operating system is Linux Mint 14 which comes with gcc and g++ version 4.7. This version is not supported by cuda 5 as it’s “too new”. The binaries of both versions are located in /usr/bin.

I installed gcc and g++ version 4.5 also but I don’t know how to reference them during the cuda 5 installation. The installation stops after the installation of the development driver during the installation of the toolkit with “unsupported gcc…”.

How can I reference gcc and g++ version 4.5 during the installation process?

speedx

Hello,

One thing worked for me is to make symbolic link from gcc-4.5 to gcc.