installing OpenCV Contrib for Nano

Hello I have been having issues trying to add the OpenCV Contrib to the standard build from the tutorial. How do I uninstall OpenCV and reinstall with Contrib library?

I have tried 3.3, 3.4, 4.0 and I keep getting make errors. Is there a T4L build already have everything installed? having to search for ways to install some modules is a big pain when the installs don’t work.

Any help is greatly appreciated.

This script is created by other forum moderator and it installed the Contrib lib.

I found the fix. The issue for me using Nano, with the jetson build from the quick start tutorial, was you need to purge the old OpenCV. Then increase your memory size using this tip from

Then modify this script to use 4.1.0 OpenCV. Will need to modify curl commands on line 32 to use wget since curl doesn’t work on Nano out of the box.

I originally used a 32Gb card, but increase it to 64Gb and the install worked great.

Comment to the moderator
Thanks for your help, but a comment. Could you guys fix the
script to be used on the Nano which includes download for 4.1.0 and increase memory use.