Internet connection to Jetson nano

I have a Jetson nano that is running Ubuntu 20 LTS. I need internet access on the jetson. Currently, the only internet connection that I have is on my USB wps internet connection from a WiFi device
I am trying to connect to laptop through microusb but not detecting try screen

Why not just let both device connect to the same wifi AP and then they can ping each other.

I dont have a wifi adapter or network card, all I have is a USB wps internet connection from a wifi dongle

I don’t really understand what does that mean “USB wps internet connection from a wifi dongle”.

What kind of device is that? And where does that wifi dongle connect to?

And which device has usb wps device? What is that USB wps internet doing here?

Can I ask you a doubt that why the device is not detecting /dev/ttyACM* is not coming
I have done
1.Inserted the microSD card (with 4GB system image already written to it) into the slot on the underside of the Jetson Nano module.
2. Jumper the J48 Power Select Header pins.
3. Connected my laptop to the developer kit’s Micro-USB port.
4. Connected a DC power supply to the J25 Power Jack.

but still not detecting device
lsusb says

It has lots of reason to cause such problem. Honestly, It is not an easy one to debug.

ttyACM0 requires

  1. The device side is running nv-l4t-usb-device-mode.service without problem.

  2. The usb cable is good enough

  3. The host side has the driver to support this interface.

You have to make sure each of them is fine. Honestly, most users have problem in point 3 because their host does not have those driver supported. Also, so far only ubuntu host supports it.

how to install or check my ubuntu system has it

Connect the micro usb cable between your host and nano and dump the dmesg on your host.

4067107.366761] usb 2-1.7: new high-speed USB device number 8 using ehci-pci
[4067107.475910] usb 2-1.7: New USB device found, idVendor=0955, idProduct=7020
[4067107.475912] usb 2-1.7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[4067107.475913] usb 2-1.7: Product: Linux for Tegra
[4067107.475914] usb 2-1.7: Manufacturer: NVIDIA
[4067107.475915] usb 2-1.7: SerialNumber: 0334817020339
[4067107.478083] rndis_host 2-1.7:1.0 usb0: register ‘rndis_host’ at usb-0000:00:1d.0-1.7, RNDIS device, d2:8b:72:8b:8d:e6
[4067107.478633] cdc_acm 2-1.7:1.2: ttyACM0: USB ACM device
[4067107.479342] usb-storage 2-1.7:1.4: USB Mass Storage device detected
[4067107.479494] scsi host6: usb-storage 2-1.7:1.4
[4067107.495329] cdc_ncm 2-1.7:1.5: MAC-Address: 76:3f:9d:4d:74:e6
[4067107.495557] cdc_ncm 2-1.7:1.5 usb1: register ‘cdc_ncm’ at usb-0000:00:1d.0-1.7, CDC NCM, 76:3f:9d:4d:74:e6
[4067108.049556] cdc_ncm 2-1.7:1.5 enp0s29u1u7i5: renamed from usb1
[4067108.075104] rndis_host 2-1.7:1.0 enp0s29u1u7: renamed from usb0
[4067108.318020] IPv6: ADDRCONF(NETDEV_UP): enp0s29u1u7: link is not ready
[4067108.359901] IPv6: ADDRCONF(NETDEV_UP): enp0s29u1u7i5: link is not ready
[4067108.359977] IPv6: ADDRCONF(NETDEV_UP): enp0s29u1u7i5: link is not ready
[4067108.399306] cdc_ncm 2-1.7:1.5 enp0s29u1u7i5: 425 mbit/s downlink 425 mbit/s uplink
[4067108.431287] cdc_ncm 2-1.7:1.5 enp0s29u1u7i5: 425 mbit/s downlink 425 mbit/s uplink
[4067108.463319] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s29u1u7i5: link becomes ready
[4067108.499487] scsi 6:0:0:0: Direct-Access Linux File-Stor Gadget 0409 PQ: 0 ANSI: 2
[4067108.499844] sd 6:0:0:0: Attached scsi generic sg3 type 0
[4067108.500432] sd 6:0:0:0: Power-on or device reset occurred
[4067108.501059] sd 6:0:0:0: [sdc] 32768 512-byte logical blocks: (16.8 MB/16.0 MiB)
[4067108.501678] sd 6:0:0:0: [sdc] Write Protect is on
[4067108.501679] sd 6:0:0:0: [sdc] Mode Sense: 0f 00 80 00
[4067108.502292] sd 6:0:0:0: [sdc] Write cache: disabled, read cache: enabled, doesn’t support DPO or FUA
[4067108.505909] sdc:
[4067108.508782] sd 6:0:0:0: [sdc] Attached SCSI removable disk

You shall see something like below.
Thus, rndis_host, cdc_acm and cdc_ncm driver are needed.

when I searched for rndis_host, cdc_acm and cdc_ncm driver in dmesg, rndis_host is present but other 2 are not there
Is that the issue

Yes, cdc_acm is for the ttyACM0 interface, so it cannot be missed.

Can I install that?

This is your host. Not jetson.

Make the decision by yourself.

now I installed the driver and see my dmesg
but still device not accessible

Then please try better micro usb cable.

yes I tried with better micro usb cable for data tranfer on which earlier I was using.

In the dmesg, My cdc_acm driver is fine right?

I am not getting the output on the monitor even if I try with the hdmi cable and microusb power adapter and removed the jumper.

FYI, if this is running 20.04 on the Jetson (and not 18.04), then there might be parts not running (e.g., perhaps running 20.04 has broken some of the USB content).

you mean my jetson nano is not on ubuntu host due to the ubuntu os version has some usb bug in it?

The host PC only matters when flashing. However, the Jetson itself by default (currently) would have Ubuntu 18.04, not 20.04. If the Jetson is Ubuntu 20.04, then it is running a lot of modifications and I’d expect things to break till reverting it to 18.04. This wouldn’t be a bug, it would be a case of conflicting software. Is your Jetson itself running Ubuntu 18.04 or is it running Ubuntu 20.04? You can ignore your host PC Ubuntu version unless you are flashing.