JetsonNano; MicroUSB cannot link to the host computer

I need to set the oem-config account and password; I boot the system first time after flush the SD card, follow the steps below;https://developer.nvidia.com/embedded/learn/get-started-jetson-nano-devkit#setup

First I use Micro USB cable (only wires, no voltage level exchage) to connect computer (win10), I cannot found the com port, not any response; as shwn below; finally I have try other normal Jetson Nano module, this Micro USB hasn’t response.

Also I connect UART debug poart (with UART to USB transfer card), and the putty can open this com port to get some start up log.

So the question is why the my Micro USB cannot connect to host PC? (J48 is bridged, use the round connector to power the module; I have try two kits, same result) So I cannot get the oem-config interface. So it must use the MicroUSB to set the oem-config at first startup, Not the debug UART port?!

Starting kernel …

[ 0.000000] Booting Linux on physical CPU 0x0
[ 0.000000] Linux version 4.9.140-tegra (buildbrain@mobile-u64-4263) (gcc version 7.3.1 20180425 [linaro-7.3-2018.05 revision d29120a424ecfbc167ef90065c0eeb7f91977701] (Linaro GCC 7.3-2018.05) ) #1 SMP PREEMPT Fri Oct 16 12:32:46 PDT 2020
[ 0.000000] Boot CPU: AArch64 Processor [411fd071]
[ 0.000000] OF: fdt:memory scan node memory@80000000, reg size 48,
[ 0.000000] OF: fdt: - 80000000 , 7ee00000
[ 0.000000] OF: fdt: - 100000000 , 7f200000
[ 0.000000] Found tegra_fbmem: 00800000@92cb4000
[ 0.000000] earlycon: uart8250 at MMIO32 0x0000000070006000 (options ‘’)
[ 0.000000] bootconsole [uart8250] enabled
[ 1.081359] tegradc tegradc.1: dpd enable lookup fail:-19
[ 1.254794] imx219 6-0010: imx219_board_setup: error during i2c read probe (-121)
[ 1.254822] imx219 6-0010: board setup failed
[ 1.965407] cgroup: cgroup2: unknown option “nsdelegate”
[ 3.271181] using random self ethernet address
[ 3.279393] using random host ethernet address
[ 3.594066] random: crng init done
[ 3.597501] random: 7 urandom warning(s) missed due to ratelimiting
[ 4.454531] using random self ethernet address
[ 4.454533] using random host ethernet address

Ubuntu 18.04.5 LTS xxxxx-desktop ttyS0

xxxxx-desktop login:
(here still cannot input anything)

There is a message showing: USB 1-2-4-port1: Cannot enable, Maybe the USB cable is bad?

I already change a developkit and MicroUSB cable, what’s the possible problem?

Hi,
If you use the developer kit, the micro-B port supports only device mode. If you connect it to host PC, you should see a folder L4T-README popping up. If it does not happen, suggest change the cable for a try.

Hello I have try again with new Micro USB cable ,with newly installed Ubuntu18.04 system, newly flashed SD card, and another develop kit. Inside the J48 is bridged for device mode.
The image I use is according to the operation below: is that correct ?

image

When I plug the MicroUSB, still haven’t found the “cdc_acm 2-1.7:1.2: ttyACM0: USB ACM device” the USB interface; then I plug the HDMI displayer to the kit, there is a error “USB1-2.4-port1: unable to enumerate the USB device”
below is some sreenshoot, please help to find the problem, really thanks.





the board is inside the box, I have try two kits, same result.

I have try, the Micro USB is just has no nay response. What’s the possible problem? wait your reply, thanks

@slyinhirain
When you connect the micro USB to your host machine at normal boot,
check whether ‘L4T-README’ is shown and 192.168.55.100 is enabled on your host side.
Micro B USB of the Jetson works mass storage and virtual network.

Hi slyinhirain,

Check your output logs, you need complete system configuration setup on /dev/ttyACMx first.
Please reference below steps:

1. Connect micro-USB cable to J28 port
2. Power on the Jetson-Nano device
3. Check /dev/ttyACM* on your host machine:
    $ ll /dev/ttyACM*
    $ sudo picocom -b 115200 /dev/ttyAMC0
      (You can use other debug tools to open)
4. Complete the system configuration setup for first time boot up.

Hello thanks very much; the problem is solved, I change a MicroUSB cable, the UART debug port can be log in with the user name and passward.
Te original one is a ordinary cable, I don’t know why it doesnt work.

1 Like

thanks for the reply, I change a cable, the problem is resolved.

1 Like