Jetson Nano from microUSB not detected when I ran dmesg

Hi, I connected my Jetson Nano using a microUSB cable to my laptop and ssh-ed inside it. It could ssh in but there was a network error and I could not run sudo apt-get update. I was googling how to resolve this and tried to disable my bridge connection using the following commands as per here (Is it safe to remove l4tbr0 Bridge network on Jetson Xavier? (Solved) - #3 by mnabati):

sudo systemctl disable nv-l4t-usb-device-mode.service
sudo systemctl stop nv-l4t-usb-device-mode.service

However, after this, I am now unable to SSH inside my Nano using the microUSB. I ran dmesg --follow on the terminal and I saw that the connection to the USB port from the Nano was not even recognised (I tried all the ports on my computer but did not work). I also tried using 3 different micro-USB to USB cables. I then used the cables on another board (OpenCR) and dmesg correctly showed me that I am connecting the board to my computer USB port.

Does anyone know how I can rectify this problem? Thanks!

The above will stop the micro-B USB cable from working as a network device, which implies address “192.168.55.1” will no longer work. This is ok if you are using something else, e.g., if wired ethernet goes to a common router, then you can use that address.

In terms of bridging you didn’t say what you were doing. However, if you are trying to give access to the internet from the Jetson over the USB, then you must re-enable and start nv-l4t-device-mode.service should you choose to bridge over USB. It isn’t always obvious, but when bridging fails it is usually the host PC needing changes and not the Jetson itself. If you happen to be using a common router over regular ethernet, then it would probably be the router needs internet access and you could ignore bridging.

Btw, stopping nv-l4t-usb-device-mode.service, if the system is fully booted, is why lsusb won’t show anything when you insert the cable (there would no longer be a device since stopping the service stops emulating devices). On the other hand, if the Jetson is in recovery mode, then you should always see a device from dmesg upon plugin of the micro-B USB cable.

Do start a new thread though.

1 Like

Got it, thanks for the explanation!