NVIDIA Jetson Nano SSH problems (works with ethernet but not microUSB)

I can ssh into my Nano using an ethernet cable (ssh rdc@ I am unable to do so using my microUSB cable(ssh rdc@
The IP addresses are different as per ifconfig. When I type the same password that I can successfully ssh in with my ethernet cable for when I am ssh-ing in with my microUSB, it keeps returning Permission denied, please try again. When I tried sudo service ssh status when attempting to ssh with microUSB cable, I get the following output:

Sep 10 00:00:47 praveen-ThinkPad-T470 sshd[2045]: Invalid user rdc from port 48836
Sep 10 00:00:49 praveen-ThinkPad-T470 sshd[2045]: pam_unix(sshd:auth): check pass; user unknown
Sep 10 00:00:49 praveen-ThinkPad-T470 sshd[2045]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=
Sep 10 00:00:51 praveen-ThinkPad-T470 sshd[2045]: Failed password for invalid user rdc from port 48836 ssh2

When I tried ssh-ing repeatedly with microUSB and checked ssh status, I noticed that the port in the Invalid user rdc from port 48836 always changes. I would appreciate some help, thanks!

When the micro-B USB is plugged in to the Jetson it functions in device mode. One such device is the ethernet you are speaking of, but the Jetson’s default address on such ethernet is I suspect you are using the wrong IP address when I see notes about

Also note that if you monitor “dmesg --follow” on the host PC as you insert the USB cable to the host PC you will see devices discovered during the plugin. One such note will show the MAC address of the virtual USB wired ethernet device. Not all host PC installations allow USB devices without some sort of “ok” from the user, and so you might need to use an app such as “sudo nm-connection-editor” (if you don’t have this you can use the built in network admin apps, or else “sudo apt-get install network-manager-gnome”) to tell the host PC that the interface is allowed.

On your host PC, if you run commands “ifconfig” and “route”, then I suspect you don’t have an interface for the “192.168.55.x” network, and any routes you might have probably don’t name a route to that subnet. Once the interface is marked as usable and not forbidden this should change.

Hi, I did enable the interface on the Network Manager as per your suggestion, and now the IP address of the Nano when connected using the microUSB shows as shown in the picture below. When I ping the IP address, I am able to get the data packets. However, when I attempt to ssh in using the password that I set for my Nano, it keeps saying Permission denied, please try again.

You’re almost there! The address is that of your local PC, not the Nano. What you’re doing when you try to ssh to is to ssh from your PC to your PC, which likely is not set to accept ssh. The address of this interface, at the Nano side, is “”. So:

Great, I’ll try this out. Thank you!