Access Denied when attempting to connect Nano via SSH

Trying access Jetson Nano via SSH and when I type in the password I get Access Denied. I can ping the Nano and have confirmed the password is correct. I’ve tried wireless and using a USB cable. The image is the latest Jetpack 4.4. Any suggestions on what to check or what is going on?
Thanks,
Brian Mc.

Greetings @briansandy37,

could you please share the error message you get when access is denied?

Unfortunately whether it is through Power Shell or Putty, when I enter the password, all I get is Access Denied or Permission Denied and then it asks for the password again. There is no other message. I’ll boot into the Nano with keyboard and monitor to confirm the password is correct and try again with the same results. I’ve connected the Nano to my laptop via a USB Data Cable and tried that route with the same results.

Do you have a linux machine at your disposal, so that you can try to ssh into the device? In doing so you’d get further information on the error through the output console. So far the problem is being described in a generic way.

ssh daemon is probably not running after boot due to error in trying to start using systemd.

You can rectify by adding the sshd start command using init.d in Startup Applications.

Add this command:

    sudo /etc/init.d/ssh restart

Damian,
I added the command as instructed and rebooted the Nano. I tried to remote in from the desktop and got the same message: Permission denied.
I then tried to remote in from a Linux machine and got the same message: Permission denied. Just to ensure the daemon was restarted on the Nano I opened a terminal window, typed in the command. It asked for the password so I entered it, confirming the password.
I got the following message: “Restarting ssh (via systemctl): ssh.service.” I then tried to remote in from the Linux machine and got “Permission denied”.

Thank you

@briansandy37 try to ssh into user-name@192.168.55.1 with a USB cable connecting your host machine to Nano’s micro USB connector.

I connected the Nano to the Laptop with the cable. Presently the laptop is treating it as a flash drive
When I hover over the icon it shows “/media/brian/L4T-README”. Needless to say trying to ssh in yields the same results; “permission denied”

Thank you for your help

Attaching the Nano via USB to a Windows laptop probably won’t work as it mounts it as a media drive as you say. Connecting from a Linux machine or Mac is more likely to work.

With the Windows laptop, there could be a couple of things going on here.

Try running on the Nano:

sudo systemctl restart ssh.service

Then make sure you are allowed to connect to SSH from your Windows machine as per:

If that still fails, try using the other sshd startup command on the Nano:

sudo /etc/init.d/ssh restart

Then try to reconnect from your Windows laptop. If that fails, try again connecting from a Linux machine or Mac.