Connecting Jetson Nano To Host PC Via Ethernet Wire

Hi all,

I successfully managed to connect to my Jetson Nano through SSH with putty by using USB(Windows host)-Micro USB(Jetson Nano)
image

image

Now i try to do the same, but with an ethernet wire to increase the distance of use of my headless nano.

I tried crossover wire between my Windows 10 to my Jetson Nano and normal ethernet wire, but putting a switch between the two, it was not successful…

When I plug the wire to enable the communication I get this in my windows 10:

image
(sorry it is in French)

As I understand, the IP address is 169.254.36.142, but when I try to ping it when I disconnect the jetson nano I have answers, which is not characteristic of good communication, normally no answers is waited:
image

Moreover, when I wired the two, on the Jetson Nano running the command ifconfig or ip address did not show me any IPv4 address, I had to manually set it. Maybe that is wrong?

Anyway, I do not understand much here… when I looked on the internet, many people was talking about DHCP server, but I do not know what to do with it.

When using putty with the 192.168.55.1 SSH connection port 22 with USB(Windows host)-Micro USB(Jetson Nano), it directly works.
Here by ethernet it does not work at all.

Can someone provide me a tutorial on how to connect from one laptop to the jetson nano, with a direct connection or with a switch? Or few advises?

My configuration:
Jetpack 4.5.1
OpenCV 4.1.1
TensorRT 7.1.3
CUDA 10.2
cuDNN 8.0

Thank you if you answer me :)

Regards.

When you connect with the USB cable, the “usb device mode” software on Nano acts as a DHCP server and gives the 192.168.55.100 address to windows and sets itself to 192.168.55.1. When you connect the Nano via ethernet directly to a Windows machine, both the Nano AND Windows machines are looking for a DHCP from which to get ip address and don’t find any.

It’s easy to set up but a lot depends on your environment. For instance, do the Windows machine and the Nano need to be connected directly or can they both be part of an existing network? How does the Windows machine get an ip address for it’s public network? Does it even connect to a public network? Do you have a network that al;ready has a DHCP server on it?

1 Like

Thanks for the answer and quick explanation.

I need to do real time test on my Jetson Nano for a project of detecting and counting cars on the road. The purpose of linking the Windows PC to the Jetson Nano through an ethernet wire would have been to enable not to put a screen, a mouse and a keyboad next to the board for doing my test, but monitoring all the system at a certain distance, represented by the ethernet wire. I can do it with the USB(Windows host)-Micro USB(Jetson Nano) but I would prefer by ethernet wire to increase a bit more the distance between the two.

I would prefer to connect them directly if possible.
My Windows laptop uses the internet connection share of my mobile phone 4G through USB to navigate on the internet, I have no other network available for putting my PC with ethernet to. Moreover, using the internet is not necessary, I only do that when having trouble, like now ^^

Once connected together, I do not understand what to do to set them up so that they understand their IP address.

Regards.

The easiest way to do this is going to be to just configure both Windows and the Nano with static ip addresses. On the windows machine, Go to Control Panel, Network and Internet, Internet Sharing Center, Change adapter settings. Right click on your ethernet adapter and click Properties, then double-click on Internet protocol Version 4 and make it look like this…
image

On the Nano desktop, you should be able to follow the instructions on this web page to set a static ip address… https://linuxize.com/post/how-to-configure-static-ip-address-on-ubuntu-18-04/#configuring-static-ip-address-on-ubuntu-desktop Set the nano address to 192.168.56.1

Now you should be able to just plug a regular ethernet cable between the two.

1 Like

Hi,

Many thanks it worked :)

Here how I did precisely because of not having the admin rights on Windows 10:

Plug Ethernet wire between the Windows 10 and Jetson Nano.

Go into the Windows 10 internet settings to see what IP address has been attributed to Windows 10
image

A 169.254.133.X IP address variant has to be set on the Jetson Nano.
image

image

I can ping the Jetson Nano on the Windows 10 terminal.
image

I can ssh to the Jetson Nano with Putty:
image

Last time I did almost the same things, but I did not put any Gateway value on the Jetson Nano. I think because of that I did not work.

Anyway, many thanks for your answers, I hope it will also help others with the same issue if they find the post.

Regards.

1 Like