Cannot ping over USB using dli-nano image

I am trying to follow the basic ‘setting up your Jetson nano’ tutorial and cannot get past the ‘headless device mode’ step.
I have tried many times to follow the tutorial as closely as possible, but it’s completely broken. I can connect to the device
from my host machine using monitor /dev/ttyusbmodem* and even verify that it is assigned the IP address of
Yet, I cannot even ping it from my host machine, let alone access the Jupyter web server on the Jetson I so desperately
need to begin this course. The image I’m using is ainano_v1-1-1_20GB_200203B.img.

So far, Nvidia has created a very unsatisfactory introductory training experience.

Hi tubsandcans,

Is this the "Getting Started With Jetson Nano Developer Kit"instruction you followed?
If not, could you provide the link of the instruction you mentioned? Also the image link URL.

Hi tubsandcans,

After flash Jetson Nano SD Card image v1.1.1.
Please following this page steps to logging into the JupyterLab server.

  • Don’t forget to connect USB cable (micro-B to type-A) and using ‘ifconfig’ to check you can see ‘’ on your target.

@kayccc - no it’s the “Getting Started with AI on Jetson Nano” > “Setting up your Jetson Nano” > “Setup and First Boot” course.

@carolyuu - thanks for the response, but I have gone over and over this very step to no avail.

Some operating systems have different requirements for a USB virtual ethernet adapter. Is your host PC Linux? If not, you might want to describe it. Windows in particular seems to have some issues.

@linuxdev - I’m running OS X - Catalina.

Some steps in the tutorial have separate instructions for different platforms, so I assume when there is no platform-specific instruction, it is valid on all platforms.

This is a valid assumption, and if there is any incompatibility on any platform with purported support, this needs to at least be mentioned.

Hi tubsandcans,

Can you see the “” ip address on your Nano?
Please list below command information:

$ head -1 /etc/nv_tegra_release

Are you connect USB cable from Jetson-Nano to Ubuntu host machine or Windows system?

@carolyuu - yes I can see interface ‘l4tbr0’ has inet address

dlinano@jetson-nano:~$ head -1 /etc/nv_tegra_release
# R32 (release), REVISION: 3.1, GCID: 18186506, BOARD: t210ref, EABI: aarch64, DATE: Tue Dec 10 06:58:34 UTC 2019

As mentioned above, I’m running osX Catalina

The presence of the “” address says the USB has set up to become a virtual wired ethernet device. The only thing left is for the host PC being connected through the correct cable to take advantage of this. At least in theory, when this cable plugs in to the PC the PC should use DHCP to ask the Nano to assign an address (the Nano acts as a router as well as an ethernet device), and that address the PC sees would be “” (with a netmask of “”). From what you’ve posted all indications are that the Nano is set up as capable of providing a DHCP response when a DHCP request is received. Everything else is up to the host.

I don’t know if different operating systems (as hosts) have different security or other requirements to allow this. Generally speaking, Ubuntu will just use the device by default. Are you absolutely sure your host is not configured in some way to block either randomly connected USB ethernet devices, or to firewall against that address?

@linuxdev - Thank you for pointing me in the right direction. I had to add the Jetson Nano as a network device on my host machine.

On OS X, you have to go to System Preferences > Network and then add new network device ‘Linux For Tegra’. Once that is done I can access it as the tutorial suggests.

Nvidia’s course tutorial for this really needs to include a note about this for Mac users, since this cost me days before being able to get started.