Network timeout over USB while doing "Getting Started with AI on Jetson Nano" course

I haven’t seen this issue addressed thus the new thread. As the subject says I’m setting up my Jetson Nano following the “Getting Started…” course instructions.

The Jetson Nano is:

  • Booting (confirmed with HDMI)
  • Using the correct image:
  • Showing the login page
  • Occasionally allowing me to login but it will always time out

Usually it times out on login but sometimes it will time out after login. I’ve tried different USB cables. I’ve tried updating my USB drivers. I removed my PiHole from the network (didn’t think this would be a problem but I figured I’d purify any kind of potentially odd routing). I’ve tried in both Chrome and Firefox. I’ve had the most “success” with Chrome. I’ve tried going to both and

Very frustrating. Any ideas?

Hi, jpwick

Could attach more information about the timeout?
The password for dlinano is right the the same with its account. usr: dlinano passowrd: dlinano is just ok. And also could share your host system? Windows or linux, Mac OS?

Nano will run the dhcp server and dispatch an IP to the host. You also can access via the SSH.

Thanks for your response. For the weblogin I am using dlinano and that works (when it doesn’t timeout)
Host system is Windows

I will try to login with ssh/putty tonight and let you know.

Your last comment is interesting: should I connect my PC via Ethernet to the nano? If I do that then it will be difficult to follow the online tutorial. That said, I have had better luck when I close all of my other network activity. Could this be down to the browser getting confused about which interface to use (Ethernet vs USB)?

You can connect to the Nano via the router(Nano and your PC both in the same subnetwork). Direct connection between Nano and your PC will not work.

You also can access via your new ip address get from the router via the ethernet. just replace the
something like The juyper will notice you to rename the workspace. Both the workspace from USB/ethernet can work together.

Everything is working great now that I put it on my main network but I still don’t understand what I was doing wrong with the USB interface. If I’m using USB does the USB IP address need to be on the same subnet as my router?

USB IP address is fixed and the nano behavior as a router. Users do not need to do anything for that.

Try to switch to the peformance mode.

sudo nvpmodel - m 0 && sudo jetson_clocks

and power the nano with 5V/4A DC supplier to see if there is some improvement.