Coneection Problems

I bought the Jetson Nano kit from sparkfun and I’ve been having some problems.
The first and most important is that I can’t seem to connect to headless mode with either powershell or tera term.
The connection seems to time out and I get errors like:
“ssh: connect to host port 22: Connection timed out”
Or if I’m lucky (fast and repetitive enough) to actually connect and be able to type my password in, I’ll get this error within about 3 seconds after the welcome screen.
“client_loop: send disconnect: Connection reset”

I am using the included barrel power supply and I obviously put the jumper on. I’m also using the included usb cable so there should be no problems. Also I followed the course to the letter, except for the exception below and have the newest version of the OS as of 2 weeks ago.

Sooo, what am I doing wrong?
I really could use some help.
Thanks all :)

On a side note, I thought I’d mention one more problem I had but solved with the tutorial.
When setting up the swap space the command “sudo echo “/mnt/4GB.swap swap swap defaults 0 0” >> /etc/fstab” didn’t work for me and I needed to use vi to edit fstab (which worked, but it kind of miffed me that the course had such a huge problem out of the gate).
I should mention the error I got was that I didn’t have proper permissions (can’t remember the exact wording, but yes I did not forget to use the sudo command).

Am I the only one getting so many problems with this beginners course?

The usb-ethernet port (micro usb port) required a good quality of micro usb cable here. Thus, please also try other cable too.

Hi, I’m having this problem too. I connect to and it works for several seconds, then resets with the error:

client_loop: send disconnect: Connection reset

Per this post, I’ve tried several different micro usb data cables and they all have the same problem. Can someone assist as it’s driving me crazy!


Is there any other device in your environment that is also using IP

No- I’ve tried pinging in terminal (just times out), and checking on IPScanner, and nothing shows.

Sometimes pinging will sporadically return packets, sometimes it times out. Fairly random.

Most of my success in connecting has come using Putty and Serial connection: Com6, 11500. But I’m trying to follow the NVidia Developer course and do things per that. I can’t connect headlessly to the page for Jupyter, whether via the Serial, or sporadically functioning SSH connection.

I’ve tried different laptops, different cables, new MicroSD card and reflashing, nothing works (I was able to briefly access over Putty SSH and then it immediately disconnected). Can I please get some assistance. Thankyou.

Sorry for not responding sooner, I had some urgent medical issues that came up.

Can anyone confirm that they have a new installation (not updated) of the latest OS for the Jetson Nano that worked perfectly when ssh’ing into it? This would be super helpful to me and steer me in the right direction.

The usb cable I’m using is the one included in the sparkfun kit, so for the money I spent I hope it is good enough quality.
I don’t have any other devices using that ip.
I’ve tried multiple times and tried everything I can think of.

Maybe I just have bad luck or something, because it seems like this course has 2 issues so far.
I’m sure the “sudo echo” command was not my fault, as there is nothing to screw up at that point.
As for this issue, I’ve not ruled out the possibility that I screwed something up, but I normally don’t have issues like this and when I do…I fix them lol.

Although I have to say I’m stumped on this one (I was hoping not to have to look at logs and whatnot for a course and product that should work out of the box…except for the OS).
I guess I’ll have to pick apart the OS until I find something or a useful log. Although I’m a bit out of touch on using linux, so it might take me a while, so don’t hold your breath (you’ll pass out).

Well if anyone comes up with the solution to this problem or can tell me what I’m doing wrong, I be forever grateful.

Thanks all :)

I think we should clarify this situation again.

We are not sure if this is really a “ssh” problem. Actually, I have 6 jetson platforms on my side and every of them can be remote accessed by me through ssh. SSH just requires you to use IP, and it does not limit where this IP comes from.

For example, this is just a virtual interface that will be established when you connect the flash port on Nano to host machine with usb cable. As you may know, such mechanism requires some usb drivers help between each side.

If the host does not have such driver, then it has chance to fail. If you insist using this interface, I can only suggest you change different cable and check the dmesg (kernel log) when you plug the usb cable to host and see what does it say.

If you want to save your time debugging this issue, maybe you can just connect a ethernet cable to jetson nano, get the IP and use the IP to interact with host.

Thanks for letting me know.
I was already reading the /var/log/auth.log and getting nowhere in a hurry :)
I didn’t copy it, I typed it from my laptop (so forgive any errors).

sshd[10595]: Accepted password for flandre from port 54708 ssh2
sshd[10595]: pam_unix(sshd:session): session opened for user flandre by (uid=0
systemd-logind[4147]: New session 6 of user flandre.

Looks good to me (I think…).

Although I still think it’s not the cable (as I’ve tried like 5 cables before giving up). Although I did check dmesg and found nothing meaningful or out of place (too much to type, but nothing sticks out as out of place).

That a really good point in the fact that the ip is virtual and is just a way to connect to the usb.
Although I’m still stuck and pulling my pretty blonde hair out of my head (well close to it).
I mean, I have a windows surface book 2 and it’s fully updated with the current usb drivers.
I can’t believe I’m close to the only one who is experiencing this problem.

I’ll try some other things before I call it quits (which I’m not good at doing).
And I’ll definitely try connecting thought the ethernet, as that will say whether the problem is the protocols or the usb.

Thanks for the info and I’ll keep plugging away :)

Just tried it out and the ethernet connection works perfectly fine.
So it’s very likely a problem with the usb.

Now to figure out what that problem is…
That was as super helpful suggestion and I’m super grateful for everyone’s help.

I’m going to take a guess that it’s not the nano, as too many people use it and would have noticed this problem. So I’m going to try some other computer and different operating systems and see what happens (just to narrow it down a little more).

Thanks again :)

I have the same problem.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.