Server Connection Error

I have installed the recommended heatsink fan and I am getting a system that consistently looses connection. I have the correct barrel power supply 5V 5A and pwm cooling fan.

I keep getting the Server Connection error. I am unable to connect via SSH to run the tegrastats or even use the terminal connection. I only have the power supply hooked up, the cooling fan and the micro usb for the connection.

Server Connection Error
A connection to the Jupyter server could not be established. JupyterLab will continue trying to reconnect. Check your network connection or Jupyter server configuration.

Refreshing the screen just gives an unable to connect error.
I am unable to maintain a connection long enough to do any diagnostics. Here is what I was able to see on my first SSH connection, and in 2 seconds I got disconnected again.

dlinano@192.168.55.1's password:
Access denied
dlinano@192.168.55.1's password:
Welcome to Ubuntu 18.04.2 LTS (GNU/Linux 4.9.140-tegra aarch64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage

This system has been minimized by removing packages and content that are
not required on a system that users do not log into.

To restore this content, you can run the 'unminimize' command.

244 packages can be updated.
2 updates are security updates.

Last login: Fri Jun 14 21:43:05 2019 from 192.168.0.43
dlinano@jetson-nano:~$

Might I have a bad board?
Any assistance would be greatly appreciated. I plan on doing some really innovative solutions in the healthcare industry. I just need this working.

Thanks,
Charles


3 Likes

It’s unlikely you have a bad board. This is most likely one of three problems:

  1. Some network infrastructure problem.
  2. Some software setting/configuration problem.
  3. Some user error that’s not obvious from the information given.

Are you using a WiFi adapter, or the built-in Gigabit Ethernet port?
How are you running the Jupyter server on the board? Do you get any kind of log message when it fails?
What does “ip addr” show when run in the terminal of the board itself (not SSH)?
Can you start Jupyter server from a terminal on the board itself (not SSH) and see what it prints in the logs?

I am running it headless, there is no network since I am using the micro USB connection to the device.
I have a fixed route on the laptop to 192.168.55.1.

Are you using a WiFi adapter, or the built-in Gigabit Ethernet port?
No network other than micro USB. There are no peripherals connected at all.

How are you running the Jupyter server on the board? Do you get any kind of log message when it fails?
The image is directly from the “Getting Started with AI on Jetson Nano” course with no modifications.

What does “ip addr” show when run in the terminal of the board itself (not SSH)?
192.168.55.1

Can you start Jupyter server from a terminal on the board itself (not SSH) and see what it prints in the logs?
NO.

The only reason I used SSH is because @snarky recommended to for information. However I can get the SSH to stay up long enough. “(It’s a good idea to run tegrastats in a SSH window from another computer, so you don’t lose the output just because the Nano shuts down!)” - @snarky

It sounds like some kind of software problem with the USB based network interface.
Having not used that interface, I can’t really recommend anything more than “look through dmesg” and “check the output of ‘journalctl -xb’” to look for error messages.
Also, if you know networking, debugging the connections with “route -n” and “ip link” and “ifconfig” and all the rest.
The network problem may also be on the host (laptop?) itself. Are you using any enterprise “client management” software? Anti-virus software? Any interesting log messages from networking on the host?

One thing you might want to try would be to connect the board to a “real” network – the same network your laptop is on.

Hi charlesg,

Have you tested with a different USB cable?

I also had continual Server connection Error when trying to run headless over USB. I tried a different USB cable and it made no difference. I also plugged into a USB 3.0 port but since the cable and the Nano are USB 2.0, that made no difference either.

I looked at the link with a Wireshark Analyzer and did not see any specific errors. However I admittedly don’t understand most of the packet transfer there. I will say there is a LOT of packet flow between the host and the Nano. Perhaps too much for USB?

So to get working again, I hooked up the keyboard, mouse and monitor to the Nano. I then plugged in the Ethernet connector and let the Nano get a DHCP address from the same network my host is on. After noting the IP Address it acquired, I was able to access JupyterLab from the host browser at that address :port 8888. It now works flawlessly.

I was having similar issues, and similarities to previous embedded board work with RNDIS suggested this was possibly Windows 10 foolishness at work (with respect to its “intelligent” labeling of networks as “Private” vs “Public” based on…who knows; some heuristics)

Anyways, here is what I did to stabilize things: (NOTE: this is specifically for WINDOWS 10)

  1. follow the instructions from NVIDIA’s various getting started guides to get the board up in “headless mode” via the USB cable (ethernet-over-usb) connection.
  2. In Windows 10’s settings, go to the “Network & Internet settings” screens (there are a few ways to get here, so i’ll leave this as a generic description)
  3. select “Change adapter properties”, which should bring up a file-explorer -like window of different NIC adapters you have (physical and virtual).
  4. Find one that describes itself as “Remote NDIS compatible…” or somesuch thing. If none say this, disconnect all hardwired ethernet cables/adapters running to your machine, and pick the last “Ethernet” icon in that window that is still active…double click this to bring up a status dialog
  5. in that status dialog, select the button “Properties”, and the dialog will change.
  6. Unselect TCP/IPv6 in that list (* may not be necessary but I did it anyways to eliminate variables)
  7. Select TCP/IPv4 and click the Properties button…another dialog will come up
  8. for the address properties, put
    192.168.55.55 as the address
    255.255.255.0 as the netmask
    192.168.55.1 as the gateway
    (you can leave the DNS settings untouched)

click apply/ok…all the way back out.
At this point, Win10 may reenumerate the network , give it a new name (e.g. Network 2) and ask if you want your PC to be discoverable. Say YES. (near as i can tell, this marks it as a “Private network” in its weird terminology.
Regardless of whether it asks or not, go ahead and unplug the USB cable and replug it, for good measure.

ANOTHER IMPORTANT NOTE:
On one machine, there was a lot of latency and page loading errors even with these steps. The problem seems to be that the “primary” network adapter (the WiFi connecting it to the internet) was set up to be on the 192.168.x.y network with a netmask of 255.255.0.0…which makes it overlap with the Nano’s 192.168.55.x network. Ordinarily, this would be resolved with routing table metrics values, but…again…Windows! (big shrug).

Hope this helps.

6 Likes

Thanks for your kind help, it works!

1 Like