Unable to ssh from USB or wifi

I have been having intermittent success trying to ssh into my 2GB jetson nano. The first time I tried it I was able to ssh via wifi for about an hour and it worked great.

When I use a USB connection, the computer detects the USB is attached, but I still cannot ssh. Most of the time i get a ‘timeout’ message. Every once in a while, it will ask for my password, connect, the immediately the connection is reset by the host.

When I attempt to ssh on wifi, Its a crap shoot trying to guess the ip address. The only way i’ve been able to do it successfully is to attach a monitor and keyboard to the jetson and query the ip address directly.

I already re-flashed the micro SD and this has not helped. I’m a relative newbie to linux and the ssh command. Can anyone help me?

What was the IP you are using to access the board through USB?

I was using 192.168.55.1 which works briefly

Could you reboot the host, hotplug the micro usb cable and see if it can be resolved?

BTW, why the topic mentions WIFI? Looks like you don’t have any issue with wifi.