Require help to SSH from my PC to my jetson nano

Hello,

I am trying to SSH from my PC (Windows 10 enterprise) to my Jetson Nano (Ubuntu 18.04).
We are on the same network.
I am able to SSH into it with my friend’s laptop (similar configurations), but not with my own.
Everytime I try (using PuTTy) I get an error saying the connection timed out.
If I try to ping it, I get a similar message saying my request timed out.
But I am able to ping my laptop from the Jetson.

I have tried disabling my firewall but it didn’t help.

What could the issue be? Is there anything else I could try?

@srirakshavijayaraghavan,

What version of JP are you using and is your Nano a 4GB or 2GB. If it is a 2GB you need to put the WiFi USB module on an extender to get it away from the processor. If it is a 4GB did you install the M2 WifFi module?

Are you using the wired ethernet? Or USB virtual wired? Or WiFi (something I don’t much personally care for, it has so many possible issues)?

Update: I got it to work. There was a problem with my OpenSSH Server and I reinstalled it on the Power shell following these steps: Install OpenSSH | Microsoft Docs

It was able to connect after that

I was on wired ethernet. There is some issue with the wifi drivers so I am unable to use them.

@TCIII I am using the 2GB version. There was an issue with my WiFi drivers so I use an ethernet connection. I solved the issue by reinstalling my Open SSH server which was giving me issues.

FYI, you can just use any valid address. The “192.168.55.1” address is only for the network over the virtual wired USB network. Your router via real ethernet will probably give you superior performance anyway.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.